Bug 1284737 - Geo-replication is logging in Localtime
Geo-replication is logging in Localtime
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On: 1282331
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 22:57 EST by Aravinda VK
Modified: 2016-04-19 03:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282331
Environment:
Last Closed: 2016-02-15 01:29:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2015-11-23 22:57:41 EST
+++ This bug was initially created as a clone of Bug #1282331 +++

Description of problem:
Geo-rep is logging in Local time, all other Gluster logs are in GMT/UTC. It is very difficult to co-relate Geo-rep logs with other Gluster logs.

How reproducible:
Always

--- Additional comment from Vijay Bellur on 2015-11-16 01:58:07 EST ---

REVIEW: http://review.gluster.org/12583 (geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-16 09:33:43 EST ---

REVIEW: http://review.gluster.org/12583 (geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-18 23:27:32 EST ---

REVIEW: http://review.gluster.org/12583 (geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-21 09:19:59 EST ---

REVIEW: http://review.gluster.org/12583 (geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-23 12:55:25 EST ---

COMMIT: http://review.gluster.org/12583 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 41e900199d7f369862b21b739dd11602d0d7c48d
Author: Aravinda VK <avishwan@redhat.com>
Date:   Mon Nov 16 12:26:00 2015 +0530

    geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC
    
    Geo-rep is logging in Local time, all other Gluster logs are in
    GMT/UTC. It is very difficult to co-relate Geo-rep logs with
    other Gluster logs.
    
    BUG: 1282331
    Change-Id: Ieae8bda7e4788e587cf4595e21e0e772c210cfbb
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/12583
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 1 Vijay Bellur 2015-11-23 22:58:39 EST
REVIEW: http://review.gluster.org/12723 (geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2015-11-24 02:48:34 EST
REVIEW: http://review.gluster.org/12723 (geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC) posted (#2) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 3 Vijay Bellur 2015-12-02 01:22:50 EST
REVIEW: http://review.gluster.org/12723 (geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC) posted (#3) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 4 Vijay Bellur 2015-12-02 10:29:17 EST
COMMIT: http://review.gluster.org/12723 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 22c6724b72f57778a686bf8dafa4a495e6907316
Author: Aravinda VK <avishwan@redhat.com>
Date:   Mon Nov 16 12:26:00 2015 +0530

    geo-rep: Fix Geo-rep logging to log datetime in GMT/UTC
    
    Geo-rep is logging in Local time, all other Gluster logs are in
    GMT/UTC. It is very difficult to co-relate Geo-rep logs with
    other Gluster logs.
    
    BUG: 1284737
    Change-Id: Ieae8bda7e4788e587cf4595e21e0e772c210cfbb
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/12583
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
     (cherry picked from commit 41e900199d7f369862b21b739dd11602d0d7c48d)
    Reviewed-on: http://review.gluster.org/12723
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 5 Kaushal 2016-04-19 03:49:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.