Bug 1284746 - tests/geo-rep: Existing geo-rep regressino test suite is time consuming.
tests/geo-rep: Existing geo-rep regressino test suite is time consuming.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
:
Depends On: 1227624
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 00:23 EST by Kotresh HR
Modified: 2016-04-19 03:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1227624
Environment:
Last Closed: 2016-04-19 03:49:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2015-11-24 00:23:39 EST
+++ This bug was initially created as a clone of Bug #1227624 +++

Description of problem:
Existing geo-rep regressino test suite is rigorous time consuming.
A simple geo-rep regression test suite is required to give results
soon to developers for the patchset.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
On patch submission

Actual results:
Takes long time around 45 minutes.

Expected results:
It should not take so much time.
It should be simple and faster.
Comment 1 Vijay Bellur 2015-11-24 00:56:37 EST
REVIEW: http://review.gluster.org/12726 (tests: New simple geo-rep regression test suite) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)
Comment 2 Vijay Bellur 2015-11-24 00:56:40 EST
REVIEW: http://review.gluster.org/12727 (tests: Fix return value in geo-rep tests) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)
Comment 3 Vijay Bellur 2015-11-24 00:56:46 EST
REVIEW: http://review.gluster.org/12728 (tests: Increase sleep timing for geo-rep) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)
Comment 4 Vijay Bellur 2015-11-27 04:32:11 EST
COMMIT: http://review.gluster.org/12726 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 9cbe0fa66c264b6afe295c32d2bae29411d01756
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu May 28 19:26:00 2015 +0530

    tests: New simple geo-rep regression test suite
    
    This is a new simple regression test suite for
    geo-replication. This is written keeping in mind
    the run time for regression test. The existing
    regression test suite is rigorous one and could
    be run nightly. Hence the existing geo-rep tests
    are being removed as part of this.
    
    Also re-enable geo-rep regression with this patch.
    
    Thanks Aravinda for initial template and plan.
    
    BUG: 1284746
    Change-Id: I9eea88c267d9e838022b7c9201e2ba4bb04f612e
    Reviewed-on: http://review.gluster.org/11058
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12726
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 5 Vijay Bellur 2015-11-27 04:33:04 EST
COMMIT: http://review.gluster.org/12727 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit cdb7b58b5036e4d7e0ed1906c55338723a4109e8
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu Aug 13 13:11:32 2015 +0530

    tests: Fix return value in geo-rep tests
    
    Remove the function 'data_tests' and TEST
    each fop in testcase itself to determine
    the exact test that fails.
    
    BUG: 1284746
    Change-Id: I34cb9cf863084adeade3b7188d3604026116a914
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/11907
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/12727
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 6 Vijay Bellur 2015-11-27 06:54:24 EST
COMMIT: http://review.gluster.org/12728 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 7de27f1445ffa7b60a5d8092681267531f50395e
Author: Kotresh HR <khiremat@redhat.com>
Date:   Tue Sep 1 11:24:09 2015 +0530

    tests: Increase sleep timing for geo-rep
    
    Increase sleep timing to let the data
    sync.
    
    NOTE: The corresponding master branch's patch
          http://review.gluster.org/12072 also
          removes geo-rep tests from bad tests.
          That is not done here as the configuration
          of regression machines is yet to be fixed
          for geo-rep.
    
    BUG: 1284746
    Change-Id: I9aa993e80a5ed706b37ebb15f61da14da48e4b72
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12072
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-on: http://review.gluster.org/12728
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 7 Raghavendra Talur 2016-03-08 14:59:52 EST
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.
Comment 8 Mike McCune 2016-03-28 18:52:26 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Kaushal 2016-04-19 03:49:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.