Bug 1284756 - [RFE]- add DPDK installation support OSP-d
[RFE]- add DPDK installation support OSP-d
Status: CLOSED DUPLICATE of bug 1325680
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Shai Revivo
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 02:12 EST by Eran Kuris
Modified: 2016-07-21 07:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-21 07:52:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eran Kuris 2015-11-24 02:12:10 EST
Description of problem:
OSP-director should support DPDK installation.
https://review.openstack.org/#/c/138742/4/specs/kilo/ml2-dpdk-ovs-mechanism-driver.rst 

To run OVS+DPDK testing you need the following packages:
http://download.eng.bos.redhat.com/brewroot/packages/openvswitch-dpdk/2.4.0/0.10346.git97bab959.1.el7/x86_64/openvswitch-dpdk-2.4.0-0.10346.git97bab959.1.el7.x86_64.rpm


# rpm -qa |grep openv
python-openvswitch-2.4.0-1.el7.noarch
openstack-neutron-openvswitch-2015.1.2-2.el7ost.noarch
openvswitch-dpdk-2.4.0-0.10346.git97bab959.1.el7.x86_64
[root@puma06 ~]# rpm -qa |grep dpdk
dpdk-2.1.0-3.el7.x86_64
openvswitch-dpdk-2.4.0-0.10346.git97bab959.1.el7.x86_64



NOTE: Once installed, need to edit /etc/sysconfig/openvswitch to add an
extra line like this:
DPDK_OPTIONS=" -l 1,3 -n 4 --socket-mem 1024,1"

http://download.eng.bos.redhat.com/brewroot/packages/dpdk/2.0.0/9.el7/x86_64/dpdk-2.0.0-9.el7.x86_64.rpm*

kernel needs to be booted with hugepages
GRUB_CMDLINE_LINUX="crashkernel=auto rd.lvm.lv=rhel_netqe9/root
rd.lvm.lv=rhel_netqe9/swap console=ttyS1,115200 intel_iommu=on iommu=on
default_hugepagesz=1GB hugepagesz=1G hugepages=32"

SELINUX needs to set to permissive for now as there are some AVC
issues that need to resolved --- I will submit a bug against this issue.

qemu-kvm-rhev-2.2.0-9 needs to be used for vhostuser.

Version-Release number of selected component (if applicable):
For OSP- 8 Liberty we should have to support of DPDK installation 

OSP-d should verify that the equipment-machines have nic's that support DPDK  &  cpu that support SSSE3 


How reproducible:
always

Steps to Reproduce:
1.Try to deploy OSP with osp-d and set DPDK 
2.verify that all packages are installed 
3.

Actual results:
there is no installation option with ospd 
Expected results:
osp-d should support all features 

Additional info:
Comment 3 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Ofer Blaut 2016-07-21 07:52:01 EDT

*** This bug has been marked as a duplicate of bug 1325680 ***

Note You need to log in before you can comment on or make changes to this bug.