Bug 1284781 - Smart variable with space in its name allowed to create. Actually It should not.
Summary: Smart variable with space in its name allowed to create. Actually It should not.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: orabin
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1324632
Blocks: 1278718
TreeView+ depends on / blocked
 
Reported: 2015-11-24 08:45 UTC by Jitendra Yejare
Modified: 2019-09-26 13:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:22:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot Attached. (212.12 KB, image/png)
2015-11-24 08:45 UTC, Jitendra Yejare
no flags Details
[Verified] Screenshot Attached (68.18 KB, image/png)
2016-05-19 12:45 UTC, Jitendra Yejare
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 12577 0 None None None 2016-04-22 15:35:59 UTC

Description Jitendra Yejare 2015-11-24 08:45:17 UTC
Created attachment 1098065 [details]
Screenshot Attached.

Description of problem:
Smart Variable with space in its name allowed to create in a puppet class. Which should not be allowed.
And also after creating the smart variable, it is not viewable, editable and deletable too.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201511181617git2fc4d6d.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to create a smart variable with name having blank space, from Config -> Classes -> Class -> Smart Variables tab.

Actual results:
Smart Variable with space in its name allowed to create in a puppet class.

Expected results:
1.Smart Variable with space in its name should not be allowed to create in a puppet class.
2. There should be a proper error message displayed saying space not allowed in variable name.

Additional info:

Comment 3 Bryan Kearney 2015-11-24 16:06:35 UTC
Connecting redmine issue http://projects.theforeman.org/issues/12577 from this bug

Comment 4 Bryan Kearney 2015-11-24 17:06:16 UTC
Upstream bug component is Provisioning

Comment 5 Bryan Kearney 2015-12-17 07:05:31 UTC
Upstream bug assigned to orabin

Comment 6 Bryan Kearney 2015-12-17 07:05:33 UTC
Upstream bug assigned to orabin

Comment 7 Bryan Kearney 2016-01-12 11:07:25 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12577 has been closed
-------------
Ori Rabin
Applied in changeset commit:54188a7c45c79df42387cba7025b2e7f9a3fbe2a.

Comment 8 Jitendra Yejare 2016-01-27 12:38:39 UTC
This issue is still reproducible in upstream.

Build : foreman-1.11.0-0.develop.201601251557git59dc77b.el6.noarch

Comment 10 Jitendra Yejare 2016-03-14 10:38:28 UTC
The issue is reproducible in latest Satellite 6.2 snap 3.
I can create a smart var with blank space in it and also after creating the smart var is not view-able, editable, delatable from Configure -> Classes -> class -> Smart variable.

Comment 11 orabin 2016-03-14 13:07:05 UTC
The smart variable won't be saved, the issue here is that you can't see the validation message.
I created another upstream issue for the hidden validation: http://projects.theforeman.org/issues/14183.

Comment 16 Jitendra Yejare 2016-05-19 12:45:55 UTC
Created attachment 1159463 [details]
[Verified] Screenshot Attached

Comment 17 Jitendra Yejare 2016-05-19 12:46:11 UTC
Verified !
@Sat 6.2 Snap 11

While adding/updating a smart variable with white space in key name, the error shown as "Can't contain spaces.". This is an expected behavior.

The verification Screenshot attached.

Comment 18 Bryan Kearney 2016-07-27 11:22:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.