Bug 1284784 - NUMA node configuration is updated even if you hit cancel
NUMA node configuration is updated even if you hit cancel
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity high (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Roman Mohr
Artyom
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 03:53 EST by Roman Mohr
Modified: 2016-02-18 06:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Cancel button in the 'NUMA Pinning' dialogue had the same effect as the 'OK' button because when dragging NUMA nodes around the changes were already done on a concrete VM outside of the context of the dialogue Consequence: When dragging NUMA nodes around and clicking 'cancel' the change was silently persisted when saving the VM configuration. Fix: Only manipulate a view which updates the real VM when clicking OK and does nothing when klicking CANCEL. Result: Cancel button works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:10:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: exception+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49517 master MERGED webui: Fix numa pinning dialog cancel button 2016-01-12 07:07 EST
oVirt gerrit 51639 ovirt-engine-3.6 MERGED webui: Fix numa pinning dialog cancel button 2016-01-13 10:20 EST

  None (edit)
Description Roman Mohr 2015-11-24 03:53:14 EST
Description of problem:
When entering the numa pinning dialog through VM-Configuration -> Host -> 'Numa pinning' and dragging around the numa nodes, the cancel button has no effect. Clicking 'Cancel' and opening the dialog again still shows the new configuration.

Note that this only happens after you have already persisted the VM configuration with numa nodes at least once.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure VM with numa nodes
2. Save VM configuration
3. Edit VM configuration
4. Enter numa pinning dialgo through VM configuration dialog
5. Drag around the numa nodes
6. Click "Cancel" and persiste the VM configuration

Actual results:
Canceled numa configuration changes get persisted


Expected results:
The last saved numa configuration or the last configuration change where 'OK' was clicked in the numa pinning dialog should be persisted.

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-26 23:24:57 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-26 23:24:57 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 3 Red Hat Bugzilla Rules Engine 2015-12-16 16:35:53 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 4 Artyom 2016-02-01 08:23:14 EST
Verified on rhevm-webadmin-portal-3.6.3-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.