Bug 1284786 - 389-ds-base: ldclt -e randomauthid Segmentation fault.
Summary: 389-ds-base: ldclt -e randomauthid Segmentation fault.
Keywords:
Status: CLOSED DUPLICATE of bug 1229799
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks: 1284791
TreeView+ depends on / blocked
 
Reported: 2015-11-24 08:57 UTC by Stanislav Zidek
Modified: 2015-12-09 01:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1284791 (view as bug list)
Environment:
Last Closed: 2015-12-09 01:22:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stanislav Zidek 2015-11-24 08:57:23 UTC
Description of problem:
Segmentation fault..

Version-Release number of selected component (if applicable):
389-ds-base-1.3.4.0-19.el7.x86_64
(and also 389-ds-base-1.3.4.0-21.el7_2.x86_64)

How reproducible:
always

Steps to Reproduce:
1. ldclt  -e randomauthid   -e esearch='*'  -f 'cn=*'   -n 1  -T 1


Actual results:
ldclt version 4.23
/usr/bin/ldclt: line 55:  2035 Segmentation fault      (core dumped) ${dir}/${COMMAND} "$@"


Expected results:
no segfault

Additional info:
# gdb /usr/bin/ldclt-bin core.2035 
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-80.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/ldclt-bin...Reading symbols from /usr/lib/debug/usr/bin/ldclt-bin.debug...done.
done.
[New LWP 2035]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `/usr/bin/ldclt-bin -e randomauthid -e esearch=* -f cn=* -n 1 -T 1'.
Program terminated with signal 11, Segmentation fault.
#0  __strlen_sse2_pminub () at ../sysdeps/x86_64/multiarch/strlen-sse2-pminub.S:38
38		movdqu	(%rdi), %xmm1
(gdb)

Comment 1 Noriko Hosoi 2015-11-24 12:04:21 UTC
Could you please install 389-ds-base-debuginfo and get the stacktrace?

Thanks.

Comment 2 Stanislav Zidek 2015-11-24 14:22:12 UTC
Trace in "Additional info" section is done with debuginfo installed if that's what you mean.

Comment 3 Noriko Hosoi 2015-11-25 08:19:45 UTC
(In reply to Stanislav Zidek from comment #2)
> Trace in "Additional info" section is done with debuginfo installed if
> that's what you mean.

Well, to debug, we need the stacktrace underneath of this crashed point.  Unfortunately, this does not tell us where and why the crash occurred...
> Program terminated with signal 11, Segmentation fault.
> #0  __strlen_sse2_pminub () at ../sysdeps/x86_64/multiarch/strlen-sse2-pminub.S:38
> 38		movdqu	(%rdi), %xmm1

Comment 4 Stanislav Zidek 2015-11-25 09:56:19 UTC
(In reply to Noriko Hosoi from comment #3)
> Well, to debug, we need the stacktrace underneath of this crashed point. 
> Unfortunately, this does not tell us where and why the crash occurred...
> > Program terminated with signal 11, Segmentation fault.
> > #0  __strlen_sse2_pminub () at ../sysdeps/x86_64/multiarch/strlen-sse2-pminub.S:38
> > 38		movdqu	(%rdi), %xmm1

I agree that this doesn't say much about what's happenning. Could you please elaborate a bit more on what precisely you want me to do? I will be glad to provide whatever information I can.

Comment 6 Noriko Hosoi 2015-12-09 01:22:37 UTC
The same bug is already fixed upstream (master branch).

The target of the fix is rhel-7.3.0/389-ds-base-1.3.5.

*** This bug has been marked as a duplicate of bug 1229799 ***


Note You need to log in before you can comment on or make changes to this bug.