Bug 1284800 - Remote IO error on v4 ganesha mount [NEEDINFO]
Remote IO error on v4 ganesha mount
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
Manisha Saini
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 04:33 EST by Neha
Modified: 2017-08-23 09:27 EDT (History)
7 users (show)

See Also:
Fixed In Version: rhgs-3.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 09:27:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
skoduri: needinfo? (nerawat)
skoduri: needinfo? (sraj)
skoduri: needinfo? (asoman)
skoduri: needinfo? (asoman)


Attachments (Terms of Use)

  None (edit)
Description Neha 2015-11-24 04:33:14 EST
Description of problem:

Tried this on EC and dist-rep volume. On mount point seen 'Remote IO error' 

Also there are 'Stale file handle' errors in ganesha-gfapi.log

Version-Release number of selected component (if applicable):
3.7.5-5

How reproducible:
Not Always

Steps to Reproduce:
1. Create an EC volume (8+4) and dist-rep volume (6x2)
2. configure nfs-ganesha and v4 mount on the client.
3. Run the IO in parallel mkdir/dd/linux untar.

Actual results:
Remote I/O error [mkdir]

Expected results:


Additional info:
Comment 2 Soumya Koduri 2016-01-27 06:41:50 EST
Please check how frequently this issue is seen by running the tests in a loop.
Comment 3 Soumya Koduri 2016-06-20 08:16:28 EDT
Shashank,

Could you please verify if the issue is still seen with the latest RHGS build.
Comment 6 Soumya Koduri 2017-05-03 08:12:33 EDT
Ambarish,

We think this issue no more exists. Could you please confirm if the you had run similar tests described in this bug? Thanks!

Note You need to log in before you can comment on or make changes to this bug.