Bug 1284813 - ipa-otptoken-import fails on nonexistent ldap connection
ipa-otptoken-import fails on nonexistent ldap connection
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: Regression, ZStream
Depends On: 1284414
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 04:38 EST by Jan Kurik
Modified: 2015-12-08 05:37 EST (History)
10 users (show)

See Also:
Fixed In Version: ipa-4.2.0-15.el7_2.1
Doc Type: Bug Fix
Doc Text:
Previously, connection to LDAP was held in a singleton object and creating it locally made it available in the back end. When this behavior was changed, it was not reflected in ipa-otptoken-import. As a consequence, ipa-otptoken-import was unusable because it crashed on every run. This problem has been fixed by connecting to LDAP in back end, and ipa-otptoken-import no longer crashes.
Story Points: ---
Clone Of: 1284414
Environment:
Last Closed: 2015-12-08 05:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-24 04:38:35 EST
This bug has been copied from bug #1284414 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 5 Namita Soman 2015-11-25 10:30:30 EST
Verified using ipa-server-4.2.0-15.el7_2.3.x86_64

# ipa otptoken-find --all
--------------------
0 OTP tokens matched
--------------------
----------------------------
Number of entries returned 0
----------------------------


# cat pskc1.xml 
<?xml version="1.0" encoding="UTF-8"?>
<KeyContainer Version="1.0"
    Id="exampleID1"
    xmlns="urn:ietf:params:xml:ns:keyprov:pskc">
    <KeyPackage>
        <DeviceInfo>
            <Manufacturer>Manufacturer</Manufacturer>
            <SerialNo>987654321</SerialNo>
            <UserId>DC=example-bank,DC=net</UserId>
        </DeviceInfo>
        <CryptoModuleInfo>
            <Id>CM_ID_001</Id>
        </CryptoModuleInfo>
        <Key Id="12345678"
            Algorithm="urn:ietf:params:xml:ns:keyprov:pskc:hotp">
            <Issuer>Issuer</Issuer>
            <AlgorithmParameters>
                <ResponseFormat Length="8" Encoding="DECIMAL"/>
            </AlgorithmParameters>
            <Data>
                <Secret>
                    <PlainValue>MTIzNDU2Nzg5MDEyMzQ1Njc4OTA=
                    </PlainValue>
                </Secret>
                <Counter>
                    <PlainValue>0</PlainValue>
                </Counter>
            </Data>
            <UserId>UID=jsmith,DC=example-bank,DC=net</UserId>
        </Key>
    </KeyPackage>
</KeyContainer>

# ipa-otptoken-import pskc1.xml result.xml
Added token: 12345678
The ipa-otptoken-import command was successful

# cat result.xml 
<KeyContainer xmlns="urn:ietf:params:xml:ns:keyprov:pskc" Version="1.0" Id="exampleID1">
</KeyContainer>

# ipa otptoken-find --all
-------------------
1 OTP token matched
-------------------
  dn: ipatokenuniqueid=12345678,cn=otp,dc=testrelm,dc=test
  Unique ID: 12345678
  Type: HOTP
  Owner: admin
  Manager: admin
  Vendor: Manufacturer
  Serial: 987654321
  Key: MTIzNDU2Nzg5MDEyMzQ1Njc4OTA=
  Algorithm: sha1
  Digits: 8
  Counter: 0
  objectclass: ipatokenhotp, top, ipatoken
----------------------------
Number of entries returned 1
----------------------------
Comment 9 errata-xmlrpc 2015-12-08 05:37:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2562.html

Note You need to log in before you can comment on or make changes to this bug.