Bug 1284837 - repoman crashes with add conf:
repoman crashes with add conf:
Status: CLOSED CURRENTRELEASE
Product: Repoman
Classification: Community
Component: Core (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity high
: 1.3
: ---
Assigned To: David Caro
David Caro
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 05:24 EST by Sandro Bonazzola
Modified: 2016-06-26 19:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 13:36:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49119 master MERGED Fixed conf: source parsing Never

  None (edit)
Description Sandro Bonazzola 2015-11-24 05:24:57 EST
Description of problem:

repoman -k /home/sbonazzo/RPM-GPG-ovirt.private --with-sources /var/www/html/pub/ovirt-3.5-pre add conf:/home/sbonazzo/ovirt-3.5.6_rc3.conf

crashed with:

2015-11-24 10:01:54,289::INFO::repoman.common.stores.RPM::Adding package /tmp/tmpNQU3Gf/vdsm-yajsonrpc-4.16.30-0.el7.centos.noarch.rpm to repo /var/www/html/pub/ovirt-3.5-pre
2015-11-24 10:01:54,289::INFO::repoman.common.repo::Resolving artifact source conf:/home/sbonazzo/ovirt-3.5.6_rc3.conf
2015-11-24 10:01:54,292::ERROR::repoman.common.parser::No artifacts found for source conf:/home/sbonazzo/ovirt-3.5.6_rc3.conf
Traceback (most recent call last):
  File "/bin/repoman", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/repoman/cmd.py", line 192, in main
    repo.add_source(art_src.strip())
  File "/usr/lib/python2.7/site-packages/repoman/common/repo.py", line 96, in add_source
    artifacts = self.parser.parse(artifact_source)
  File "/usr/lib/python2.7/site-packages/repoman/common/parser.py", line 96, in parse
    raise Exception(msg)
Exception: No artifacts found for source conf:/home/sbonazzo/ovirt-3.5.6_rc3.conf
2015-11-24 10:01:54,303::INFO::repoman.common.repo::Cleaning up temporary dir /tmp/tmpNQU3Gf


Version-Release number of selected component (if applicable):
1.2.1.dev29-1.el7.centos

How reproducible:
100%


Additional info:
passing directly the jenkins jobs to the add command works, so it must be related to the conf: only.
Comment 1 David Caro 2015-11-24 05:28:47 EST
(self-note) Looks like a regression, probably the conf: source it's not being picked up by the correct store

Note You need to log in before you can comment on or make changes to this bug.