Bug 1284841 - [origin_infrastructure_200] Error "json: cannot unmarshal number into Go value of type string" when following doc to setup container garbage collection
[origin_infrastructure_200] Error "json: cannot unmarshal number into Go valu...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Documentation (Show other bugs)
3.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jan Chaloupka
DeShuai Ma
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 05:37 EST by Jianwei Hou
Modified: 2016-01-21 05:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 05:21:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2015-11-24 05:37:03 EST
Description of problem:
Configure node garbage collection following https://docs.openshift.com/enterprise/3.1/admin_guide/garbage_collection.html, add following configurations to node-config.yaml, when starting openshift node, error "F1124 10:26:24.955722    3492 start_node.go:74] could not load config file "openshift.local.config/node/node-config.yaml" due to an error: json: cannot unmarshal number into Go value of type string" is displayed.

Container garbage collection setting.
```
kubeletArguments:
  minimum-container-ttl-duration:
    - 10s
  maximum-dead-containers-per-container:
    - 2
  maximum-dead-containers:
    - 100
```

Version-Release number of selected component (if applicable):
On devenv-fedora_2775
openshift v1.1-146-ge13da03
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2


How reproducible:
Always

Steps to Reproduce:
1. Follow https://docs.openshift.com/enterprise/3.1/admin_guide/garbage_collection.html to setup node garbage collection
2. sudo /data/src/github.com/openshift/origin/_output/local/bin/linux/amd64/openshift start node --kubeconfig=openshift.local.config/master/admin.kubeconfig --hostname=`hostname` --volume-dir=pwd/openshift.local.volumes --config=openshift.local.config/node/node-config.yaml


Actual results:
After step 2:
F1124 10:26:24.955722    3492 start_node.go:74] could not load config file "openshift.local.config/node/node-config.yaml" due to an error: json: cannot unmarshal number into Go value of type string

Expected results:
Should not see any error

Additional info:
After updating the values with string, node is started

Document URL: 
https://docs.openshift.com/enterprise/3.1/admin_guide/garbage_collection.html

Section Number and Name: 
Container Garbage Collection
Comment 1 Andy Goldstein 2015-11-30 11:47:31 EST
The documentation needs to be corrected. All kubeletArguments values have to be strings. In the example above, 10s, 2, and 100 need to be strings.
Comment 3 Jan Chaloupka 2015-12-01 16:57:35 EST
Merged upstream
Comment 4 DeShuai Ma 2016-01-11 01:18:05 EST
@Jan Chaloupka if this bug is fixed, could you set the status on_qa ?
Comment 5 Jan Chaloupka 2016-01-11 04:02:50 EST
I was told it is enough to set status to RELEASE_PENDING. This is documentation related. The change is already presented in openshift docs [1] in "Settings" snippets of configurations. I don't see a reason why this can not be switched to VERIFIED right away.

Can anyone from docs confirm/verify?

[1] https://docs.openshift.org/latest/admin_guide/garbage_collection.html
Comment 6 Jianwei Hou 2016-01-11 04:42:19 EST
This bug can be verified, can anyone please change it to ON_QA status? We can only change a bug to VERIFIED status from ON_QA status.
Thank you!
Comment 7 Jianwei Hou 2016-01-12 21:10:52 EST
This bug is verified.

Note You need to log in before you can comment on or make changes to this bug.