Bug 1284851 - Mate power manager doesn't detect AC/DC changes on MacBook Air with RHEL 7.2
Mate power manager doesn't detect AC/DC changes on MacBook Air with RHEL 7.2
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: mate-power-manager (Show other bugs)
epel7
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 05:53 EST by Alexander Todorov
Modified: 2015-12-16 08:23 EST (History)
3 users (show)

See Also:
Fixed In Version: mate-power-manager-1.10.2-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 08:23:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2015-11-24 05:53:48 EST
Description of problem:

I'm using RHEL 7 on a MacBook Air, early 2015 model. The battery level detection has never been very good but at least it could properly detect when the computer was running on DC or AC power. 

With the latest updates introduced with RHEL 7.2 last week it looks like this detection is broken. I'm running on battery but the icon says I'm on AC power and vice versa sometimes. 

Plugging in and out the power cord doesn't seem to have any effect. 

I've tried logging into GNOME 3 and there everything is working as expected. More over it looks to me that MATE will indicate the last known status detected by GNOME. 

So far I don't see anything in the logs and I'm not sure how to figure out what's wrong. Let me know what information you want me to provide.
Comment 1 Wolfgang Ulbrich 2015-11-24 09:47:02 EST
What version of mate-power-manger are you using?
M-P-M use upower to detect the charging state, upower was also updated with 7.2.
What does 'upower --dump' show?
Comment 2 Alexander Todorov 2015-11-24 10:04:32 EST
mate-power-manager-1.10.2-1.el7.x86_64
upower-0.99.2-1.el7.x86_64

with power connected

# upower --dump
Device: /org/freedesktop/UPower/devices/line_power_ADP1
  native-path:          ADP1
  power supply:         yes
  updated:              24.11.2015 (вт) 16,02,15 EET (3676 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    warning-level:       none
    online:              yes
    icon-name:          'ac-adapter-symbolic'

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               SMPNz451E5WF90KAB123456789ABCDE
  model:                bq20z451E5WF90KAB123456789ABCDE
  power supply:         yes
  updated:              24.11.2015 (вт) 17,03,30 EET (1 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               charging
    warning-level:       none
    energy:              61,17 Wh
    energy-empty:        0 Wh
    energy-full:         64,54 Wh
    energy-full-design:  71,5 Wh
    energy-rate:         11,915 W
    voltage:             8,505 V
    time to full:        17,0 minutes
    percentage:          94%
    capacity:            90,2657%
    icon-name:          'battery-full-charging-symbolic'
  History (rate):
    1448377410	11,915	charging

Device: /org/freedesktop/UPower/devices/DisplayDevice
  power supply:         yes
  updated:              24.11.2015 (вт) 17,03,30 EET (1 seconds ago)
  has history:          no
  has statistics:       no
  battery
    present:             yes
    state:               charging
    warning-level:       none
    energy:              61,17 Wh
    energy-full:         64,54 Wh
    energy-rate:         11,915 W
    time to full:        17,0 minutes
    percentage:          94%
    icon-name:          'battery-full-charging-symbolic'

Daemon:
  daemon-version:  0.99.2
  on-battery:      no
  lid-is-closed:   no
  lid-is-present:  yes
  critical-action: HybridSleep




on baterry:

[root@aero s3cmd]# upower --dump
Device: /org/freedesktop/UPower/devices/line_power_ADP1
  native-path:          ADP1
  power supply:         yes
  updated:              24.11.2015 (вт) 17,03,55 EET (6 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    warning-level:       none
    online:              no
    icon-name:          'ac-adapter-symbolic'

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               SMPNz451E5WF90KAB123456789ABCDE
  model:                bq20z451E5WF90KAB123456789ABCDE
  power supply:         yes
  updated:              24.11.2015 (вт) 17,03,56 EET (5 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    warning-level:       none
    energy:              61,27 Wh
    energy-empty:        0 Wh
    energy-full:         64,54 Wh
    energy-full-design:  71,5 Wh
    energy-rate:         8,021 W
    voltage:             8,506 V
    time to empty:       7,6 hours
    percentage:          94%
    capacity:            90,2657%
    icon-name:          'battery-full-symbolic'
  History (rate):
    1448377436	8,021	discharging
    1448377435	11,746	discharging
    1448377410	11,915	charging

Device: /org/freedesktop/UPower/devices/DisplayDevice
  power supply:         yes
  updated:              24.11.2015 (вт) 17,03,56 EET (5 seconds ago)
  has history:          no
  has statistics:       no
  battery
    present:             yes
    state:               discharging
    warning-level:       none
    energy:              61,27 Wh
    energy-full:         64,54 Wh
    energy-rate:         8,021 W
    time to empty:       7,6 hours
    percentage:          94%
    icon-name:          'battery-full-symbolic'

Daemon:
  daemon-version:  0.99.2
  on-battery:      yes
  lid-is-closed:   no
  lid-is-present:  yes
  critical-action: HybridSleep
Comment 3 Wolfgang Ulbrich 2015-11-24 12:00:14 EST
Ok, charging states from upower seems to be correct.
Can you please test https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-56f1789544
This update of mate-themes is for new gtk3 version in rhel7.2.
Maybe the issue is related to this misssing update.
Personal i use fedora and i don't have rhel7 installed on my notebook.
I will do this if i found some time for tying to reproduce the issue.
Comment 4 Alexander Todorov 2015-11-25 08:56:27 EST
I've updated mate-themes from epel-testing and also found m-p-m update as well:

mate-themes-1.12.0-1.el7.noarch
mate-power-manager-1.10.2-2.el7.x86_64


There doesn't seem to be any difference.
Comment 5 Wolfgang Ulbrich 2015-11-25 10:08:02 EST
(In reply to Alexander Todorov from comment #4)
> I've updated mate-themes from epel-testing and also found m-p-m update as
> well:
> 
> mate-themes-1.12.0-1.el7.noarch
> mate-power-manager-1.10.2-2.el7.x86_64
> 
> 
> There doesn't seem to be any difference.
Sure, but new m-p-m has improvements with backlight handling, now it doesn't forget the previous backlight value after reboot/suspend.

After a complete horror instalation on my notebook (the kernel was broken on iso image), i could reproduce the issue.
But it seems depend on which kernel is used.
Comment 6 Wolfgang Ulbrich 2015-11-25 13:46:57 EST
Ok, i was wrong with the kernel.
Using mate-power-manager --verbose shows me that m-p-m doesn't read any changes from upower if i plug/unplug the power cable.
upower is updated to 0.99.2 with 7.2 update, but there was a major change with upower-0.99.
The proplem is that m-p-m from epel repo is build with upower < 0.99, because the epel repo use Centos7 repo sources.
Rhel repos are not public.
When Centos do the 7.2 update i can rebuild m-p-m against new upower version.
I'm pretty shure than the issue will gone.
This affects also other packages, ie. mate-screensaver.
Here m-s freezes my notebook (intel graphic) if screensaver gets in,
...... only with latest kernel.

Sorry we have to wait for Centos update.
Comment 7 Fedora Update System 2015-11-25 17:10:50 EST
mate-control-center-1.10.2-2.el7 mate-power-manager-1.10.2-3.el7 mate-screensaver-1.10.2-4.el7 mate-session-manager-1.10.2-2.el7 mate-settings-daemon-1.10.2-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-04e22597b2
Comment 8 Wolfgang Ulbrich 2015-11-25 17:19:10 EST
Note, this update fixes the issue and suspend/hypernate on lid close.
But don't wait for this update is in stable, use updates-testing.
I will push this update to stable not before Centos7 is upgraded to 7.2, to avoid to blame other users.
Comment 9 Wolfgang Ulbrich 2015-11-25 17:21:26 EST
err......epel-testing
Comment 10 Alexander Todorov 2015-11-26 03:41:42 EST
(In reply to Wolfgang Ulbrich from comment #5)
> 
> After a complete horror instalation on my notebook (the kernel was broken on
> iso image), i could reproduce the issue.
> But it seems depend on which kernel is used.

Maybe this will help (in the future):
http://atodorov.org/blog/categories/mac/

(In reply to Fedora Update System from comment #7)
> mate-control-center-1.10.2-2.el7 mate-power-manager-1.10.2-3.el7
> mate-screensaver-1.10.2-4.el7 mate-session-manager-1.10.2-2.el7
> mate-settings-daemon-1.10.2-2.el7 has been submitted as an update to Fedora
> EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-04e22597b2


I don't see these packages in epel-testing yet and bodhi status is Pending. I will test once they become available.
Comment 11 Fedora Update System 2015-11-27 02:18:46 EST
mate-control-center-1.10.2-2.el7, mate-power-manager-1.10.2-3.el7, mate-screensaver-1.10.2-4.el7, mate-session-manager-1.10.2-2.el7, mate-settings-daemon-1.10.2-2.el7, mate-themes-1.12.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update mate-screensaver mate-settings-daemon mate-control-center mate-power-manager mate-session-manager mate-themes'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-04e22597b2
Comment 12 Alexander Todorov 2015-11-27 14:47:39 EST
(In reply to Fedora Update System from comment #11)
> You can provide feedback for this update here:
> https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-04e22597b2

mate-power-manager-1.10.2-3.el7.x86_64 fixes both the issue with AC/DC not detected and another issue with suspend/resume, reported at:
https://github.com/patjak/mba6x_bl/issues/41

Thanks!
Comment 13 Wolfgang Ulbrich 2015-11-27 14:59:43 EST
There is a reason that i rebuild more packages, please update all.
Comment 14 Alexander Todorov 2015-11-30 03:14:38 EST
I did yum update mate* --enablerepo=epel-testing.

I think I'm good.
Comment 15 Fedora Update System 2015-12-16 08:23:10 EST
mate-control-center-1.10.2-2.el7, mate-power-manager-1.10.2-3.el7, mate-screensaver-1.10.2-4.el7, mate-session-manager-1.10.2-2.el7, mate-settings-daemon-1.10.2-2.el7, mate-themes-1.12.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.