Bug 128487 - glibc breaks in RHEL3 U3 beta channel for amd64
Summary: glibc breaks in RHEL3 U3 beta channel for amd64
Status: CLOSED DUPLICATE of bug 130059
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-23 15:39 UTC by Joe Orton
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2004-07-23 15:39:23 UTC
The system appears to be hosed now so I can't give much more details.

Linux emcee.cambridge.redhat.com 2.4.21-15.EL #1 Thu Apr 22 00:20:14
EDT 2004 x86_64 x86_64 x86_64 GNU/Linux

Installing...
   1:libgcc                ###########################################
[100%]
   2:libgcc                ###########################################
[100%]
   3:XFree86-libs-data     ###########################################
[100%]
   4:glibc-common          ###########################################
[100%]
   5:glibc                 ###########################################
[100%]
Stopping sshd:[  OK  ]
Starting sshd:[  OK  ]
   6:glibc                 
########################################### [100%]
/bin/sh: error while loading shared libraries: libtermcap.so.2: cannot
enable executable stack as shared object requires: Permission denied

etc etc  watch as all subsequent %post scripts fail and system becomes
unusable.

Comment 1 Jakub Jelinek 2004-07-23 15:48:04 UTC
2.4.21-15.EL is too old (before the execstack changes).

Comment 2 Joe Orton 2004-08-07 21:50:38 UTC
In case it wasn't clear, the trigger for this bug was:

1. take an AMD64 machine running the RHEL3 U2
2. subscribe it to the U3 beta channel
3. run up2date 
4. watch everything die

I can't see how this is a kernel issue.

Comment 3 Joe Orton 2004-08-10 22:50:14 UTC
Maybe someone in QA could confirm this bug, I don't particularly want
to try it and trash my hammer box again.

Comment 4 Jay Turner 2004-08-16 19:49:36 UTC

*** This bug has been marked as a duplicate of 130059 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:04:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.