Bug 128489 - Compiler switch "-fomit-frame-pointer" breaks gstreamer build
Compiler switch "-fomit-frame-pointer" breaks gstreamer build
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-23 11:46 EDT by Steve Snyder
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 01:52:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2004-07-23 11:46:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040708

Description of problem:
Attempts to build binary packages from gstreamer-0.8.3-2.src.rpm fail
when the "-fomit-frame-pointer" switch is used.  Note that compiler
switches are specified by /etc/rpmrc.

This set of compiler switches works:

    -march=pentium4 -O2 -pipe

This set of switches stop gstreamer from building to completion:

    -march=pentium4 -O2 -pipe -fomit-frame-pointer



Version-Release number of selected component (if applicable):
gstreamer-0.8.3-2

How reproducible:
Always

Steps to Reproduce:
1. Specify compiler switches "-march=pentium4 -O2 -pipe
-fomit-frame-pointer" in /etc/rpmrc.
2. Run: rpmbuild --rebuild gstreamer-0.8.3-2.src.rpm
3. After build fails, remove the "-fomit-frame-pointer" and try again.
4. With revised set of compiler switches the build completes normally.



Actual Results:  Build fails with this output:

mkdir .libs
 gcc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libxml2 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g
-Wall -DGST_DISABLE_DEPRECATED -I../../libs -I../.. -I../.. -c
gstreamer-scan.c  -fPIC -DPIC -o .libs/gstreamer-scan.o
 gcc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libxml2 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g
-Wall -DGST_DISABLE_DEPRECATED -I../../libs -I../.. -I../.. -c
gstreamer-scan.c -o gstreamer-scan.o >/dev/null 2>&1
gcc -o .libs/gstreamer-scan .libs/gstreamer-scan.o 
../../gst/.libs/libgstreamer-0.8.so /usr/lib/libxml2.so -lpthread -lz
-lm -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -ldl -lglib-2.0
/usr/lib/libpopt.so
creating gstreamer-scan
Scan failed
make[3]: *** [scan-build.stamp] Error 255
make[3]: Leaving directory
`/usr/src/redhat/BUILD/gstreamer-0.8.3/docs/gst'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/gstreamer-0.8.3/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/gstreamer-0.8.3'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.56263 (%build)


Expected Results:  Should complete build of binary packages.

Additional info:

This is a FC2 system installed with "[] Everything" package selection
and with all updates applied.

Possibly it is not "-fomit-frame-pointer" itself that is problematic
but that switch in conjunction with the other switches shown above. 
Note though that I use "-march=pentium4 -O2 -pipe
-fomit-frame-pointer" as a matter of course and have not seen this
combination of compiler switches break any other package builds.
Comment 1 Colin Walters 2004-09-22 01:52:52 EDT
This works for me with gstreamer 0.8.5's upstream package, so
presumably it will work in rawhide too.  If you want to confirm that,
that'd be great.

I am not going to issue an FC2 update for this though.



Note You need to log in before you can comment on or make changes to this bug.