Bug 1284903 - [RFE] Command Infrastructure - support flows
[RFE] Command Infrastructure - support flows
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Moti Asayag
Moti Asayag
: CodeChange, FutureFeature
Depends On: 1302293
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 07:35 EST by Oved Ourfali
Modified: 2016-08-11 04:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 04:44:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
mgoldboi: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 41699 None None None 2016-05-04 03:58 EDT
oVirt gerrit 52961 master NEW engine: Support events in CoCo 2016-05-09 17:44 EDT

  None (edit)
Description Oved Ourfali 2015-11-24 07:35:29 EST
Command’s Flow should allow the developer to introduce a sequence of actions in the system (Command, task, event) which will be executed conditionally (or not) depending on the result of the former action in that flow.
Comment 1 Oved Ourfali 2016-04-07 08:50:02 EDT
This is an ongoing effort, partially implemented in 4.0.
Putting devel-ack.
Comment 2 Sandro Bonazzola 2016-05-02 06:03:22 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Pavel Stehlik 2016-05-05 07:00:25 EDT
QE - CodeChange, just sanity (various storage operations will work).
Comment 4 Gil Klein 2016-08-11 04:44:58 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.