Bug 1284913 - Multiple same alerts about backup
Multiple same alerts about backup
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0.1
All All
unspecified Severity medium (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 08:02 EST by Lukas Svaty
Modified: 2016-02-10 14:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-29 03:42:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2015-11-24 08:02:51 EST
Description of problem:
Alert "There is no full backup available, please run engine-backup to prevent data loss in case of corruption." is displayed every 6/18 hours in alerts. It should be displayed only once (the last one) the same as alert about power management.

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.0.3-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Do not set up backup
2. See alerts in webadmin
3.

Actual results:
Multiple alerts about backup.

Expected results:
Only one should be displayed.

Additional info:
Same bug was previously about powermanagement not being configured alert, which was spamming the alerts tab. Decision was to show every alerts only once and do not repeat it if it already exist in alerts tab.
Comment 1 Einav Cohen 2015-11-25 12:13:07 EST
marking as 'infra' as this seems related to the backup-awareness.
Comment 2 Oved Ourfali 2015-11-29 03:31:42 EST
As far as I remember, this was as designed.
Eli/Yaniv?
Comment 3 Eli Mesika 2015-11-29 03:40:38 EST
(In reply to Oved Ourfali from comment #2)
> As far as I remember, this was as designed.
> Eli/Yaniv?

Yes, it was intended and we wanted to insure that this alert is handled and not ignored.
So, best practice to remove this alert is to have a cron job that uses engine-backup to generate a daily backup

Note You need to log in before you can comment on or make changes to this bug.