Bug 1284947 - Integration pack: camel-core does not run in Java 1.6
Integration pack: camel-core does not run in Java 1.6
Status: CLOSED WONTFIX
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Fuse Integration (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Edson Tirelli
Jiri Petrlik
Petr Penicka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 09:06 EST by Jiri Petrlik
Modified: 2015-11-24 10:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 10:35:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Petrlik 2015-11-24 09:06:35 EST
Description of problem:

The integration package for BxMS 6.2.0.CR1 and Fuse 6.2.1 uses "camel-core:2.15.1.redhat-621070" package, which does not run on Java 1.6. This can cause problems in containers, which are capable to run under Java 1.6 (for example EAP 6.4). It can also cause problems in FSW, because FSW currently supports OpenJDK 1.6.

Version-Release number of selected component (if applicable):

Integration pack build: intpkg-1.2.0.redhat-005. (http://dev138.mw.lab.eng.bos.redhat.com/candidate/intpkg-1.2.0.redhat-005/)

How reproducible:

Use integration pack in Java 1.6:
java.lang.UnsupportedClassVersionError: org/apache/camel/CamelContext : Unsupported major.minor version 51.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

Note You need to log in before you can comment on or make changes to this bug.