Bug 128495 - luit hangs on UTF-8 terminal and 8-bit locale
luit hangs on UTF-8 terminal and 8-bit locale
Status: CLOSED DUPLICATE of bug 141992
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://bugs.freedesktop.org/show_bug....
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2004-07-23 12:43 EDT by Tomasz Ostrowski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 17:01:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org (Old) 2443 None None None Never
FreeDesktop.org 1400 None None None Never

  None (edit)
Description Tomasz Ostrowski 2004-07-23 12:43:15 EDT
Description of problem:
On UTF-8 terminal (gnome-terminal, xterm or console) luit often hangs.
Sometimes it just says "Couldn't copy terminal settings".

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-5.i386.rpm

How reproducible:
At least 2 in 3 tries.

Steps to Reproduce:
1. LANG=en_US.UTF-8 gnome-terminal
2. luit date
3. luit date
4. luit date
5. luit date
6. luit date
7. luit date
8. luit date

Actual results:
[hang] [ctrl-c]
[hang] [ctrl-c]
Fri Jul 23 18:36:00 CEST 2004
[hang] [ctrl-c]
[hang] [ctrl-c]
Fri Jul 23 18:36:24 CEST 2004
[hang] [ctrl-c]
Couldn't copy terminal settings

Expected results:
Fri Jul 23 18:39:51 CEST 2004
Fri Jul 23 18:39:52 CEST 2004
Fri Jul 23 18:39:53 CEST 2004
Fri Jul 23 18:39:54 CEST 2004
Fri Jul 23 18:39:55 CEST 2004
Fri Jul 23 18:39:56 CEST 2004
Fri Jul 23 18:39:57 CEST 2004

Additional info:
1. FC1 version of luit works

2. When I've copied FC2 version of luit and libfontenc.so.1.0 to FC1
computer and used "LD_PRELOAD=./libfontenc.so.1.0 ./luit date" it also
hanged.
Comment 1 Tomasz Ostrowski 2004-10-19 13:07:17 EDT
Just checked on Fedora Core 3 Test 3 - it also hangs. Changing product
version to fc3test3.
Comment 2 Mike A. Harris 2005-03-07 12:04:23 EST
Does this problem occur in Fedora Core 3 final release, with
all FC3 updates applied?
Comment 3 Tomasz Ostrowski 2005-03-10 08:00:52 EST
Yes, this problem occurs in FC3 with xorg-x11-6.8.1-12.FC3.21,
glibc-2.3.4-2.fc3 and kernel-2.6.10-1.770_FC3 (Pentium III, 192MB
RAM). It also occurs in Fedora Rawhide with xorg-x11-6.8.2-7,
glibc-2.3.4-14 and kernel-2.6.11-1.1177_FC4 (Celeron 2.4GHz, 256MB RAM).

Changed version to devel. Or maybe I should change it to FC3?

It is significant bug I think - luit is very usefull for launching
no-UTF-aware console programs in UTF locale. This includes for example
slrn, pine etc. (LC_ALL=pl_PL luit slrn).
Comment 4 Mike A. Harris 2005-04-15 06:56:19 EDT
Ok, please file a bug report in the X.Org bugzilla located at
http://bugs.freedesktop.org in the "xorg" component, which will increase
the number of developers aware of the problem, and maximize an
earlier resolution.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.
Comment 5 Mike A. Harris 2005-04-15 06:57:06 EDT
Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.
Comment 6 Mike A. Harris 2005-05-17 01:47:00 EDT
There hasn't been any feedback on this bug in just over 2 months now,
and no response to my previous request in comment #4 to file the issue
in X.Org bugzilla so that the official maintainers of the software
are aware of the issue.

As such, it is assumed that the latest update fixes the issue or that
there is no further interest in tracking this problem, so I am closing
it as "ERRATA".  If this is an incorrect assumption, please follow
the steps in comment #4 if you are still interested in seeing the
problem resolved, and we will track the problem in X.Org bugzilla
and will review any bug fixes that become available for consideration
in future updates.

Setting status to "ERRATA"
Comment 7 Tomasz Ostrowski 2005-05-17 05:39:16 EDT
This bug is covered in XOrg/XFree86 bugzilla:
http://bugs.freedesktop.org/show_bug.cgi?id=2443
and no, it is not resolved upstream, but there is a proposed patch:
https://bugs.freedesktop.org/attachment.cgi?id=923

If I find some spare time I can try to compile xorg RPM with this patch and
check it. I do not have much time lately though.
Comment 8 Mike A. Harris 2005-05-17 17:01:35 EDT
Thanks for the update.  The first comment of the upstream bug report points
back to another Red Hat bugzilla ID, bug #141992, which is on our "UPSTREAM"
tracker currently.

This bug report is a duplicate of bug #141992, so I'm going to close it as
a dupe as we're already tracking http://bugs.freedesktop.org/show_bug.cgi?id=2443

There is a proposed patch, but it has not been reviewed or accepted into the
Xorg CVS yet.  We will continue to monitor the upstream bug report periodically,
and once a decision has been made by X.Org, if the patch (or some other fix)
gets committed to CVS head, we will review it and flag it for inclusion in
the stable branch as well.  Eventually it should appear in a future update.

Please use the X.Org bugzilla for any updates, so everything is tracked in
the central X.Org tracker from now on. Thanks again for pointing out the bug
URLs.



*** This bug has been marked as a duplicate of 141992 ***
Comment 9 Mike A. Harris 2005-05-17 17:03:53 EDT
Adding reference to another upstream bug:

https://bugs.freedesktop.org/show_bug.cgi?id=1400

Note You need to log in before you can comment on or make changes to this bug.