Bug 1284957 - JBoss EAP6-PIT tests failed on RHEL6.7 with package java-1.7.1-ibm-1.7.1.3.20-1jpp.1.el6_7
JBoss EAP6-PIT tests failed on RHEL6.7 with package java-1.7.1-ibm-1.7.1.3.20...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: PIT (Show other bugs)
6.4.4
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Petr Kremensky
Petr Kremensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 09:35 EST by Ryan Williams
Modified: 2016-02-01 02:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 02:40:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Williams 2015-11-24 09:35:49 EST
Description of problem:

Automated tests failed while running EAP6-PIT tests triggered against a new build of IBM jdk package.

JDK package: java-1.7.1-ibm-1.7.1.3.20-1jpp.1.el6_7

Machine details:
OS: RHEL6.7
ARCH: i386

Failed test cases:
1. ibm17-org-jboss-as-test-integration-ejb-timerservice-persistence-TimerServicePersistenceSecondTestCase-testTimerServiceCalled
2. ibm17-org-jboss-as-test-integration-ejb-timerservice-serialization-TimerServiceSerializationSecondTestCase-testTimerServiceRestoredWithCorrectInfo

Jenkins job:
https://pit-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/PIT-prod-EAP64-ibm17-C6-runtest/6/

Email report:
https://pit-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/PIT-prod-EAP64-ibm17-C6-runtest/6/artifact/Always-61465296749.html
Comment 1 Petr Kremensky 2016-01-25 06:21:55 EST
Root cause of the *SecondTestCase failures is that they require *FirstTestCase to be run before them. *FirstTestCase tests are executed in basic-integration-default-web.surefire execution task, but they were not, because of ExtensionRemoveTestCase timeout (see log [1]). 

Unfortunately I am unable to reproduce the failure of ExtensionRemoveTestCase and logs doesn't give me any clue why it stuck. I can add some logic into testing branch to skip the *Second tests in case that *First were not executed for now.

[1] - https://pit-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/PIT-prod-EAP64-ibm17-C6-runtest/6/artifact/EAP6.4_rhel6_i386_Server_ibm17.01/recipes/1/tasks/1/logs/taskoutput.log
Comment 2 Ryan Williams 2016-01-29 17:28:46 EST
Re-ran the jobs with the latest version 6.4.6 and was unable to reproduce the test failures. All tests passed.
Comment 3 Petr Kremensky 2016-02-01 02:40:06 EST
Closing, fixed in 6.4.6.

Note You need to log in before you can comment on or make changes to this bug.