Bug 1284963 - Add opendaylight support to puppet-neutron
Add opendaylight support to puppet-neutron
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Tim Rozet
Itzik Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 09:45 EST by Jason Guiditta
Modified: 2016-08-10 07:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.6-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:14:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 249390 None None None Never
OpenStack gerrit 259243 None None None 2015-12-22 22:03 EST

  None (edit)
Description Jason Guiditta 2015-11-24 09:45:22 EST
Description of problem: Add ability for neutron to be configured to use opendaylight sdn. Patch is not yet posted, but is being worked on by trozet.  Once done, we will need to update opm so this can be supported in the next release.
Comment 1 Tim Rozet 2015-11-24 14:51:37 EST
Please assign this to me.  Patch:
https://review.openstack.org/#/c/249390/1
Comment 2 Tim Rozet 2015-12-22 22:06:06 EST
Backport to stable liberty is https://review.openstack.org/#/c/259243/2
Comment 5 Itzik Brown 2016-02-15 02:44:41 EST
Verified the package openstack-puppet-modules-7.0.6-2.el7ost.noarch
includes /usr/share/openstack-puppet/modules/neutron/manifests/plugins/ovs/opendaylight.pp
and 
/usr/share/openstack-puppet/modules/neutron/manifests/plugins/ml2/opendaylight.pp
Comment 6 errata-xmlrpc 2016-04-07 17:14:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.