Bug 1284967 - SELinux is preventing abrt-dump-xorg from 'execute' accesses on the file /usr/bin/Xorg.
SELinux is preventing abrt-dump-xorg from 'execute' accesses on the file /usr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:23edfb6aa475d193ca457599fd6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 09:53 EST by Alex
Modified: 2016-02-16 22:50 EST (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-158.5.fc23 selinux-policy-3.13.1-158.6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 22:50:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex 2015-11-24 09:53:40 EST
Description of problem:
SELinux is preventing abrt-dump-xorg from 'execute' accesses on the file /usr/bin/Xorg.

*****  Plugin catchall (100. confidence) suggests   **************************

If вы считаете, что abrt-dump-xorg следует разрешить доступ execute к Xorg file по умолчанию.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
чтобы разрешить доступ, выполните:
# grep abrt-dump-xorg /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:xserver_exec_t:s0
Target Objects                /usr/bin/Xorg [ file ]
Source                        abrt-dump-xorg
Source Path                   abrt-dump-xorg
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           xorg-x11-server-Xorg-1.18.0-2.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-154.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.6-300.fc23.x86_64 #1 SMP Tue
                              Nov 10 19:32:21 UTC 2015 x86_64 x86_64
Alert Count                   8
First Seen                    2015-11-16 12:23:11 CET
Last Seen                     2015-11-21 06:36:15 CET
Local ID                      a99b633b-5f04-46f9-90f6-86a5c2aa68b7

Raw Audit Messages
type=AVC msg=audit(1448084175.544:522): avc:  denied  { execute } for  pid=2583 comm="abrt-dump-xorg" name="Xorg" dev="sda4" ino=1975947 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:xserver_exec_t:s0 tclass=file permissive=0


Hash: abrt-dump-xorg,abrt_dump_oops_t,xserver_exec_t,file,execute

Version-Release number of selected component:
selinux-policy-3.13.1-154.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.6-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2016-01-21 09:58:49 EST
A new functionality?
Comment 2 Jakub Filak 2016-02-08 03:19:17 EST
Yes, we test if /usr/bin/Xorg has X attribute to make sure the found backtrace was produced by that program:
https://github.com/abrt/abrt/blob/master/src/plugins/xorg-utils.c#L106
Comment 3 Lukas Vrabec 2016-02-08 05:13:45 EST
commit acae975716c88fc93d8a11d0ed1c8bd5c6c188f4
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Feb 8 11:11:17 2016 +0100

    Allow abrt_dump_oops_t to check permissions for a /usr/bin/Xorg. rhbz#1284967
    
    AVC caused by this line in abrt:
    https://github.com/abrt/abrt/blob/master/src/plugins/xorg-utils.c#L107
Comment 4 Fedora Update System 2016-02-11 09:21:24 EST
selinux-policy-3.13.1-158.6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-36a160982c
Comment 5 Fedora Update System 2016-02-14 11:23:22 EST
selinux-policy-3.13.1-158.6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-36a160982c
Comment 6 Fedora Update System 2016-02-16 22:49:52 EST
selinux-policy-3.13.1-158.6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.