Bug 1284985 - Please backport fix for interposer
Please backport fix for interposer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robbie Harwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1284987
  Show dependency treegraph
 
Reported: 2015-11-24 10:46 EST by Simo Sorce
Modified: 2015-12-14 05:20 EST (History)
6 users (show)

See Also:
Fixed In Version: krb5-1.14-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1284987 (view as bug list)
Environment:
Last Closed: 2015-12-14 05:20:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2015-11-24 10:46:31 EST
Upstream pull request with explanation here:
https://github.com/krb5/krb5/pull/348

This is required to be able to properly interpose the gss_acquire_cred_impersonate_name() call used by some applications.
Comment 1 Robbie Harwood 2015-11-24 12:23:07 EST
I will do this once the 1.14 update has landed in Fedora (due to the way bodhi works, I need to wait here): https://bodhi.fedoraproject.org/updates/FEDORA-2015-3e75abf2a3

Is this just needed for f23 or do f22/f21 need it as well?
Comment 2 Simo Sorce 2015-11-24 13:07:08 EST
We do not have implemented impersonate_name in GSS-Proxy yet, and I was planning to land this change only in F23 for now.
If we decide to ship a newer GSS-Proxy in older Fedora versions, then we'll probably wan tto backport this fiox there too.

Let's start with F23 for now.
Comment 3 Fedora Update System 2015-12-10 15:01:46 EST
krb5-1.14-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-584b2829d6
Comment 4 Fedora Update System 2015-12-11 00:59:31 EST
krb5-1.14-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update krb5'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-584b2829d6
Comment 5 Fedora Update System 2015-12-14 05:20:29 EST
krb5-1.14-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.