Bug 1284994 - VolumeClaimSelectors [NEEDINFO]
VolumeClaimSelectors
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bradley Childs
Johnny Liu
:
: 1328278 (view as bug list)
Depends On:
Blocks: 1267746
  Show dependency treegraph
 
Reported: 2015-11-24 10:56 EST by Ivan
Modified: 2017-01-17 23:20 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-05 09:29:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
erich: needinfo? (mbarrett)
jkaur: needinfo? (bchilds)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2145211 None None None 2017-01-17 23:20 EST

  None (edit)
Description Ivan 2015-11-24 10:56:09 EST
Description of problem:
RFE

As a Openshift user i want to be able to select which volumes my persistentvolumeclaims use by applying label selectors on the PVC against labeled Volumes. Similar to the concept used by projects with nodeSelectors.
there is currently a proposal that defines this issue.  This is critical to running openshift across multiple separated environments where machines have acess to seperate NFS(storage) servers

https://github.com/kubernetes/kubernetes/pull/17056


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 9 Steve Watt 2016-02-01 12:17:21 EST
Update: This is currently being worked through the community and making good progress. See https://github.com/kubernetes/kubernetes/pull/17056
Comment 11 Steve Watt 2016-05-22 14:38:02 EDT
Update: https://github.com/kubernetes/kubernetes/pull/25917 is in progress. We are targeting it to be merged for Kube 1.3, which is targeted for the OSE 3.3 release.
Comment 12 Steve Watt 2016-05-22 14:39:45 EDT
*** Bug 1328278 has been marked as a duplicate of this bug. ***
Comment 15 Eric Paris 2016-10-05 09:29:43 EDT
Closing as this feature has been implemented and shipped as part of OpenShift 3.3.

Note You need to log in before you can comment on or make changes to this bug.