Bug 1285002 - [RFE] optimizer should not suggest to migrate VM that can't be migrated.
[RFE] optimizer should not suggest to migrate VM that can't be migrated.
Status: CLOSED DEFERRED
Product: ovirt-optimizer
Classification: oVirt
Component: General (Show other bugs)
0.9.1
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Martin Sivák
Shira Maximov
: FutureFeature
Depends On: 1180071
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 11:07 EST by Shira Maximov
Modified: 2017-06-07 11:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-07 11:55:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
optimizer suggest to migrate VM that can't be migrated. (194.26 KB, image/png)
2015-11-24 11:08 EST, Shira Maximov
no flags Details

  None (edit)
Description Shira Maximov 2015-11-24 11:07:14 EST
Description of problem:
the opta planner is recommend to migrate vm. after i click to migrate the vm, i get this error : Status: Migration start failed (409): [Cannot migrate VM. There is no host that satisfies current scheduling constraints. See below for details:, The host host_mixed_1 did not satisfy internal filter Memory because has availabe 912 MB memory. Insufficient free memory to run the VM.]

Version-Release number of selected component (if applicable):
optimizer should not suggest migrate VM that can't be migrated. 

How reproducible:
100%

Steps to Reproduce:
1. have a setup with two hosts and optimizer installed 
2. create a  big VM that consumed (almost) the Max free Memory for scheduling new VMs (to be less then 1GB) for example (if i have VM with 16G memory, then create Vm with 15G memory)
3. create 6 vm with 1BG memory 
4. optimizer will recommend to migrate a vm, try to migrate the vm and the you will get this error : 
Status: Migration start failed (409): [Cannot migrate VM. There is no host that satisfies current scheduling constraints. See below for details:, The host host_mixed_1 did not satisfy internal filter Memory because has availabe 912 MB memory. Insufficient free memory to run the VM.]

Actual results:
will get this error : 
Status: Migration start failed (409): [Cannot migrate VM. There is no host that satisfies current scheduling constraints. See below for details:, The host host_mixed_1 did not satisfy internal filter Memory because has availabe 912 MB memory. Insufficient free memory to run the VM.]


Expected results:
optimizer should not suggest migrate VM that can't be migrated. 

Additional info:
Comment 1 Shira Maximov 2015-11-24 11:08 EST
Created attachment 1098256 [details]
optimizer suggest to migrate VM that can't be migrated.
Comment 2 Martin Sivák 2015-11-24 11:16:42 EST
This is related to the change in engine's memory filter. The optimizer rules have to be updated to make sure both engine and optimizer compute the values in the same way.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-24 12:50:21 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 4 Red Hat Bugzilla Rules Engine 2015-11-26 23:16:30 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 5 Sandro Bonazzola 2016-05-02 05:51:43 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 6 Yaniv Lavi (Dary) 2016-05-23 09:15:05 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 7 Yaniv Lavi (Dary) 2016-05-23 09:19:27 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 8 Martin Sivák 2016-11-28 09:29:54 EST
This is a bit harder to fix as predicting free memory of a host multiple steps into the future requires detailed knowledge about shared pages and libraries.

I am removing it from 4.0.6 right now and we should plan it for a release with sufficient time for a proper design.
Comment 9 Red Hat Bugzilla Rules Engine 2016-12-27 11:38:13 EST
This request has been proposed for two releases. This is invalid flag usage. The ovirt-future release flag has been cleared. If you wish to change the release flag, you must clear one release flag and then set the other release flag to ?.
Comment 11 Martin Sivák 2017-06-07 11:55:17 EDT
We currently do not have resources to fix this.

Note You need to log in before you can comment on or make changes to this bug.