Bug 1285006 - Atomic diff leaks FD when comparing images are not RPM based
Atomic diff leaks FD when comparing images are not RPM based
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Brent Baude
atomic-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 11:20 EST by Alex Jia
Modified: 2016-04-07 05:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:25:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0527 normal SHIPPED_LIVE atomic bug fix and enhancement update 2016-03-31 23:20:15 EDT

  None (edit)
Description Alex Jia 2015-11-24 11:20:20 EST
Description of problem:
Atomic diff leaks FD when comparing images are not RPM based,
it's caused by a ValueError exception without executing clean
up work.

Version-Release number of selected component (if applicable):
# rpm -q atomic docker
atomic-1.7-2.git68be076.el7.x86_64
docker-1.9.0-9.el7.x86_64

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.1 (Maipo)

How reproducible:
always

Steps to Reproduce:
1. docker pull busybox
2. atomic diff -nr busybox busybox
3. df -hT

Actual results:

# atomic diff -nr busybox busybox
busybox is not RPM based.

# df | grep /tmp
/dev/dm-4                               10190100    38072   9611356   1% /tmp/d6d0332d84515366e5d0
/dev/dm-5                               10190100    38072   9611356   1% /tmp/12fca07986c8d85d76b2

Expected results:
Fix FD leaks

Additional info:

https://github.com/projectatomic/atomic/pull/234
Comment 1 Brent Baude 2015-12-02 09:42:54 EST
Corrected in PR -> https://github.com/projectatomic/atomic/pull/239
Comment 2 Brent Baude 2015-12-11 08:58:59 EST
Merged into upstream
Comment 3 Daniel Walsh 2015-12-11 09:08:05 EST
Fixed in atomic-1.8
Comment 5 Alex Jia 2016-01-20 05:30:04 EST
There is no FD leaks on atomic-1.8-2.gita35ae18.el7.x86_64, so move the bug to VERIFIED status.
Comment 7 errata-xmlrpc 2016-03-31 19:25:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0527.html

Note You need to log in before you can comment on or make changes to this bug.