Bug 1285026 - Upgrade from F22 -> F23 video failed to work after upgrade Radeon X2300
Upgrade from F22 -> F23 video failed to work after upgrade Radeon X2300
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-r128 (Show other bugs)
23
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 12:20 EST by Timothy Davis
Modified: 2016-12-20 11:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 11:14:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Davis 2015-11-24 12:20:21 EST
Description of problem:
Laptop Compaq 6910p with onboard Radeon X2300 3Gb Ram 250Gb HD
Video worked on Fedora 22 install but after dnf system-upgrade video stopped working (laptop display). Tried remove quiet and booting to console only without any luck. . Booting into F22 kernel worked for a while but then the system would just kernel crash after about a week. Installed another hard drive into the laptop and did a fresh install of F23 successfully. Ran updates and rebooted successfully.  

Version-Release number of selected component (if applicable):


How reproducible:
Unknown

Steps to Reproduce:
1. Install F22
2. Run dnf system upgrade
3.

Actual results:
Video unusable

Expected results:
Everything works

Additional info:
Please let me know what logs you need, I saved all of the logs on a flash drive
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-24 13:59:14 EST
This is unlikely to be related to the upgrade process itself. Maybe a kernel bug or a hardware failure.
Comment 2 Timothy Davis 2015-11-24 17:41:11 EST
(In reply to Zbigniew Jędrzejewski-Szmek from comment #1)
> This is unlikely to be related to the upgrade process itself. Maybe a kernel
> bug or a hardware failure.
Normally I would agree except it wouldn't explain why a clean install would operate normally.
Comment 3 Zbigniew Jędrzejewski-Szmek 2015-11-24 19:25:38 EST
Probably different kernel parameters or such. Whatever it is, the upgrade plugin is not involved, it only installs rpms.
Comment 4 Fedora End Of Life 2016-11-24 08:42:03 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2016-12-20 11:14:17 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.