Bug 1285038 - Re-exporting of nfs share gives error message if export directory has space
Re-exporting of nfs share gives error message if export directory has space
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.6
x86_64 Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Steve Dickson
Filesystem QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 12:49 EST by Shahish Nambiar
Modified: 2016-07-06 19:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 12:50:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shahish Nambiar 2015-11-24 12:49:11 EST
Description of problem:
Re-exporting of nfs share gives error "does not support NFS export" message if export directory has space.

How reproducible:
Always

Steps to Reproduce:
1. Export a directory with contain space in it

 # cat /etc/exports 
 "/tmp/This is a test"  *(rw)

2) Now re-export the nf share by restarting the nfs server or "exportfs" command:

# service nfs restart
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Starting NFS services:  exportfs: /tmp/This is a test does not support NFS export
                                                           [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]


OR

# exportfs -rv
exporting *:/tmp/This is a test
exportfs: /tmp/This is a test does not support NFS export
exporting *:/data


3) But the NFS share gets exports properly and also on client system mounting is successful.

# showmount -e <NFS_SERVER_IP>
Export list for <NFS_SERVER_IP>:
/tmp/This is a test *

# mount "<NFS_SERVER_IP>:/tmp/This is a test" /mnt -vv
mount: no type was given - I'll assume nfs because of the colon
mount: trying <NFS_SERVER_IP> prog 100003 vers 3 prot tcp port 2049
mount: trying <NFS_SERVER_IP> prog 100005 vers 3 prot udp port 50097

# mount | grep -i nfs
<NFS_SERVER_IP>:/tmp/This is a test on /mnt type nfs (rw,addr=<NFS_CLIENT_IP>)


Expected results:
Need to ignore the message "does not support NFS export" while re-exporting the nfs share eventhough the export directory has space in it.

Note You need to log in before you can comment on or make changes to this bug.