Bug 1285040 - Re-exporting of nfs share gives error message if export directory has space
Re-exporting of nfs share gives error message if export directory has space
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.6
x86_64 Unspecified
low Severity low
: rc
: ---
Assigned To: Steve Dickson
Filesystem QE
:
Depends On:
Blocks: 1269194
  Show dependency treegraph
 
Reported: 2015-11-24 12:54 EST by Shahish Nambiar
Modified: 2017-06-01 15:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-01 15:00:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shahish Nambiar 2015-11-24 12:54:34 EST
Description of problem:
Re-exporting of nfs share gives error "does not support NFS export" message if export directory has space.

How reproducible:
Always

Steps to Reproduce:
1. Export a directory with contain space in it

 # cat /etc/exports 
 "/tmp/This is a test"  *(rw)

2) Now re-export the nfs share by restarting the nfs service or with "exportfs" command:

 # service nfs restart
 Shutting down NFS daemon:                                  [  OK  ]
 Shutting down NFS mountd:                                  [  OK  ]
 Shutting down NFS quotas:                                  [  OK  ]
 Shutting down NFS services:                                [  OK  ]
 Starting NFS services:  exportfs: /tmp/This is a test does not support NFS export
                                                           [  OK  ]
 Starting NFS quotas:                                       [  OK  ]
 Starting NFS mountd:                                       [  OK  ]
 Starting NFS daemon:                                       [  OK  ]


 OR

 # exportfs -rv
 exporting *:/tmp/This is a test
 exportfs: /tmp/This is a test does not support NFS export
 exporting *:/data


3) But the NFS share gets exports properly and also on client system mounting is successful.

 # showmount -e <NFS_SERVER_IP>
 Export list for <NFS_SERVER_IP>:
 /tmp/This is a test *

 # mount "<NFS_SERVER_IP>:/tmp/This is a test" /mnt -vv
 mount: no type was given - I'll assume nfs because of the colon
 mount: trying <NFS_SERVER_IP> prog 100003 vers 3 prot tcp port 2049
 mount: trying <NFS_SERVER_IP> prog 100005 vers 3 prot udp port 50097

 # mount | grep -i nfs
 <NFS_SERVER_IP>:/tmp/This is a test on /mnt type nfs (rw,addr=<NFS_CLIENT_IP>)


Expected results:
Need to ignore/remove the message "does not support NFS export" while re-exporting the nfs share even if export directory has space in it.
Comment 4 Chris Williams 2017-06-01 15:00:47 EDT
Red Hat Enterprise Linux 6 transitioned to the Production 3 Phase on May 10, 2017.  During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not appear to meet the inclusion criteria for the Production Phase 3 and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification.  Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com

Note You need to log in before you can comment on or make changes to this bug.