Bug 1285046 - AFR self-heal-daemon option is still set on volume though tier is detached
AFR self-heal-daemon option is still set on volume though tier is detached
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: ZStream
Depends On: 1275912
Blocks: 1260923 1285978
  Show dependency treegraph
 
Reported: 2015-11-24 13:08 EST by Mohammed Rafi KC
Modified: 2016-06-16 09:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275912
: 1285978 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:46:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-24 13:22:08 EST
REVIEW: http://review.gluster.org/12736 (glusterd/tier: Reset to reconfigured values after detach-tier) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-11-25 08:28:51 EST
REVIEW: http://review.gluster.org/12736 (glusterd/tier: Reset to reconfigured values after detach-tier) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2015-11-26 01:15:38 EST
REVIEW: http://review.gluster.org/12736 (glusterd/tier: Reset to reconfigured values after detach-tier) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 4 Vijay Bellur 2015-11-26 09:45:24 EST
REVIEW: http://review.gluster.org/12736 (glusterd/tier: Reset to reconfigured values after detach-tier) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 5 Vijay Bellur 2015-11-26 14:39:21 EST
COMMIT: http://review.gluster.org/12736 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 3ef88ec70aefd278155aa485e83a2d7bba8b6663
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Nov 24 20:59:29 2015 +0530

    glusterd/tier: Reset to reconfigured values after detach-tier
    
    After detach-tier commit , we have to reset the option
    reconfigured for tier volume
    
    Change-Id: Iae0210259720d6ac14ccc0cc339dc9f54a0c4571
    BUG: 1285046
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12736
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 6 Niels de Vos 2016-06-16 09:46:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.