Bug 1285069 - Linux bash prompt becomes invisible with jline 2.12.1
Linux bash prompt becomes invisible with jline 2.12.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jline (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 14:45 EST by Omair Majid
Modified: 2015-12-09 15:49 EST (History)
6 users (show)

See Also:
Fixed In Version: jline-2.13-1.fc23, jline-2.13-1.fc24 jline-2.13-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 15:49:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for the 2.13 update (2.74 KB, patch)
2015-11-25 05:50 EST, Severin Gehwolf
no flags Details | Diff

  None (edit)
Description Omair Majid 2015-11-24 14:45:43 EST
Linux bash prompt becomes invisible with jline2 1.12.

This is the upstream bug: https://github.com/jline/jline2/issues/163

This is breaking the terminal for programs that are using jline, such as Thermostat. When such a program using jline2 exits, it somehow disables echo in the terminal, making the terminal (apparently) unusable for further interaction.

As a workaround, both `stty sane` and `reset` fix the terminal.

Please consider rebasing this package or backporting the bugfix(es).
Comment 1 Severin Gehwolf 2015-11-25 04:24:19 EST
Re-assigning component as jline2 is jline since a while.
Comment 2 Severin Gehwolf 2015-11-25 04:43:32 EST
Please consider upgrading to 2.13:
https://github.com/jline/jline2/releases
Comment 3 Severin Gehwolf 2015-11-25 05:50 EST
Created attachment 1098699 [details]
Proposed patch for the 2.13 update
Comment 4 Severin Gehwolf 2015-11-25 05:51:38 EST
Scratch build with the patch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=11977256

If nobody objects I'll push this update in a day or two to rawhide.
Comment 5 Mat Booth 2015-11-25 13:27:32 EST
No objection here :-)
Comment 6 Severin Gehwolf 2015-11-26 14:19:21 EST
Pushed and built in rawhide[1]. I wonder if it's safe to backport this to F23. Any opinions?

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=701784
Comment 7 Mikolaj Izdebski 2015-11-27 00:41:34 EST
(In reply to Severin Gehwolf from comment #6)
> Pushed and built in rawhide[1]. I wonder if it's safe to backport this to
> F23. Any opinions?

I would take advantage of Koschei - wait and see if jline 2.13 doesn't break anything in f24. Then it should be fairly safe to push this to f23.
Comment 8 Severin Gehwolf 2015-12-01 05:54:39 EST
(In reply to Mikolaj Izdebski from comment #7)
> (In reply to Severin Gehwolf from comment #6)
> > Pushed and built in rawhide[1]. I wonder if it's safe to backport this to
> > F23. Any opinions?
> 
> I would take advantage of Koschei - wait and see if jline 2.13 doesn't break
> anything in f24. Then it should be fairly safe to push this to f23.

Good idea, thanks! Since I didn't see any failures in rawhide due to the jline update I went ahead and built it for F23 too.
Comment 9 Fedora Update System 2015-12-01 05:57:51 EST
jline-2.13-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6d0a04fdc8
Comment 10 Fedora Update System 2015-12-01 17:30:29 EST
jline-2.13-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update jline'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6d0a04fdc8
Comment 11 Severin Gehwolf 2015-12-09 04:33:11 EST
FWIW, I've seen a similar issue with a failed maven build (used "mvn clean package" on a maven project that doesn't compile). After the build failure the terminal was not echoing chars any more.
Comment 12 Fedora Update System 2015-12-09 15:49:38 EST
jline-2.13-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.