Bug 1285070 - gtk 3.19.2-1 draws invisible scrollbars in Firefox.
gtk 3.19.2-1 draws invisible scrollbars in Firefox.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 14:49 EST by Valdis Kletnieks
Modified: 2015-12-18 09:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 20:13:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2015-11-24 14:49:02 EST
Description of problem:
Using gtk 3.19.2-1, the trough of scrollbars is rendered and colored correctly, but the scrollbar itself is either not rendered, or it's rendered as the same color as the trough.  Interestingly enough, it *does* think the scrollbar is there, because grabbing and dragging or clicking the invisible scrollbar works.

Reverting back to 3.19.1-1 makes it work again.

Version-Release number of selected component (if applicable):
gtk3-3.19.2-1.fc24.x86_64

How reproducible:
On a box with 3.19.2-1 installed, launch firefox, and hit a page that should have a scrollbar on it.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Valdis Kletnieks 2015-11-27 14:05:26 EST
Appears to be related to the 3.19.2 move to CSS - guessing that some CSS file is missing a specification for the scrollbar, or a wrong name for the node, or something....
Comment 2 Bill Gianopoulos 2015-12-07 10:30:58 EST
I filed this https://bugzilla.mozilla.org/show_bug.cgi?id=1230955 bug report on the Firefox side in case this is a Mozilla issue.
Comment 3 Matthias Clasen 2015-12-07 11:09:17 EST
The people working on the gtk3 firefox port are aware of the needed changes.
I've started https://git.gnome.org/browse/gtk+/tree/tests/foreigndrawing.c to help with this.
Comment 4 Bill Gianopoulos 2015-12-07 11:12:49 EST
(In reply to Matthias Clasen from comment #3)
> The people working on the gtk3 firefox port are aware of the needed changes.
> I've started https://git.gnome.org/browse/gtk+/tree/tests/foreigndrawing.c
> to help with this.

Great!  I will close the Firefox bug, but at least this way people who search Mozila's Bugzilla will find something that points them to the real issue.
Comment 5 Matthias Clasen 2015-12-17 20:13:53 EST
fixed in todays firefox build
Comment 6 Bill Gianopoulos 2015-12-18 09:43:40 EST
OK I was confused by this if the fix is to change the Firefox code I should not have closed the bug on the Mozilla side.  Whatever was done needs to be done via a Mozilla bug so that it will be included in the released product.  I am reopening this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1230955 and would like the GTK3 port team to post the code to it and get this into the release code.  as it is, getting into Firefox version 45 was missed by a week here.

Note You need to log in before you can comment on or make changes to this bug.