Bug 1285081 - yum whatprovides /usr/lib/systemd/system/nfs-rquotad.service reports nfs-utils but nfs-utils does not contain the file
yum whatprovides /usr/lib/systemd/system/nfs-rquotad.service reports nfs-util...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: quota (Show other bugs)
7.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Petr Pisar
qe-baseos-daemons
: TestCaseProvided
Depends On:
Blocks: 1203710
  Show dependency treegraph
 
Reported: 2015-11-24 15:41 EST by Dave Wysochanski
Modified: 2016-05-18 21:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 01:12:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2015-11-24 15:41:53 EST
Description of problem:
In RHEL7.0 GA nfs-utils contained the following file: 
/usr/lib/systemd/system/nfs-rquotad.service

This was removed in RHEL7.1 and following releases, but 'yum whatprovides' is still reporting it's provided by nfs-utils.

[root@rhel7u1-node1 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.8.el7.x86_64
[root@rhel7u1-node1 ~]# yum whatprovides /usr/lib/systemd/system/nfs-rquotad.service
Loaded plugins: product-id, subscription-manager
1:nfs-utils-1.3.0-0.el7.x86_64 : NFS utilities and supporting clients and daemons for the kernel NFS server
Repo        : rhel-7-server-rpms
Matched from:
Filename    : /usr/lib/systemd/system/nfs-rquotad.service


[root@rhel7u1-node1 ~]# rpm -qf /usr/lib/systemd/system/nfs-rquotad.service
error: file /usr/lib/systemd/system/nfs-rquotad.service: No such file or directory
[root@rhel7u1-node1 ~]# rpm -ql nfs-utils | grep /usr/lib/systemd/system/nfs-rquotad.service
[root@rhel7u1-node1 ~]# rpm -ql nfs-utils | grep nfs-rquotad.service
[root@rhel7u1-node1 ~]#


Version-Release number of selected component (if applicable):
nfs-utils-1.3.0-0.8.el7.x86_64


How reproducible:
every time

Steps to Reproduce:
1. yum whatprovides /usr/lib/systemd/system/nfs-rquotad.service
2. rpm -ql nfs-utils | grep nfs-rquotad.service


Actual results:
yum whatprovides /usr/lib/systemd/system/nfs-rquotad.service reports nfs-utils contains the file but the nfs-utils package does not contain the file.


Expected results:
Either the file is in the nfs-utils package, or if not, then "yum whatprovides" does not report that it is contained in nfs-utils.


Additional info:
This is related to https://bugzilla.redhat.com/show_bug.cgi?id=1207239
In the very least nfs-utils needs changed to not report it is providing this file if it no longer provides it.
Comment 1 Dave Wysochanski 2016-01-20 11:28:33 EST
This should be an easy fix.  In no case should "yum whatprovides" show inaccurate file data for any RHEL7 package.

Still a problem in RHEL7.2

[root@rhel7u2-node1 ~]# yum whatprovides /usr/lib/systemd/system/nfs-rquotad.service
Loaded plugins: product-id, search-disabled-repos, subscription-manager
1:nfs-utils-1.3.0-0.el7.x86_64 : NFS utilities and supporting clients and daemons for the kernel NFS server
Repo        : rhel-7-server-rpms
Matched from:
Filename    : /usr/lib/systemd/system/nfs-rquotad.service



[root@rhel7u2-node1 ~]# rpm -qf /usr/lib/systemd/system/nfs-rquotad.service
error: file /usr/lib/systemd/system/nfs-rquotad.service: No such file or directory
[root@rhel7u2-node1 ~]# rpm -qf /usr/lib/systemd/system/nfs-rquotad.service
error: file /usr/lib/systemd/system/nfs-rquotad.service: No such file or directory
[root@rhel7u2-node1 ~]# rpm -ql nfs-utils | grep nfs-rquotad.service
Comment 10 Petr Pisar 2016-02-17 01:12:35 EST
As shown in the command outputs, the version of installed nfs-utils package and version of nfs-utils installed package differ. Different package versions have different content. This is not a bug.

Those wanting quota package to deliver rquotad systemd unit should follow bug #1207239.
Comment 11 Petr Pisar 2016-02-17 01:14:12 EST
(In reply to Petr Pisar from comment #10)
> As shown in the command outputs, the version of installed nfs-utils package
> and version of nfs-utils installed package differ. Different package
> versions have different content. This is not a bug.
> 
Typo correction: version of installed nfs-utils package and version of nfs-utils package returned by yum differ.

Note You need to log in before you can comment on or make changes to this bug.