Bug 1285128 - Cannot update to 7.2 because packages aren't found
Cannot update to 7.2 because packages aren't found
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: gstreamer1-vaapi (Show other bugs)
epel7
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Moez Roy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 19:11 EST by Christian Hernandez
Modified: 2015-12-18 02:25 EST (History)
4 users (show)

See Also:
Fixed In Version: gstreamer1-vaapi-0.6.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 02:25:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Hernandez 2015-11-24 19:11:20 EST
Description of problem:

Cannot update to 7.2 because packages aren't found

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 7.1
epel-release-7-5

How reproducible:

Every time

Steps to Reproduce:
1. yum -y clean all
2. yum -y update


Actual results:

---
Error: Package: gstreamer1-vaapi-0.5.9-3.el7.x86_64 (@epel)
           Requires: libgstbasevideo-1.0.so.0()(64bit)
           Removing: gstreamer1-plugins-bad-free-1.0.7-4.el7.x86_64 (@anaconda/7.0)
               libgstbasevideo-1.0.so.0()(64bit)
           Updated By: gstreamer1-plugins-bad-free-1.4.5-3.el7.x86_64 (rhel-7-server-rpms)
               Not found

---

Full output - http://paste.fedoraproject.org/294188/84101891/

Expected results:

Updated system to 7.2

Additional info:
Comment 1 Orion Poplawski 2015-11-24 21:49:01 EST
RHEL7.2 bumped the soname of libgstbasevideo.  Hopefully a rebuild should do the trick.
Comment 2 Christian Hernandez 2015-11-30 20:08:03 EST
Update:

When I try and run "yum -y update" with "--skip-broken" I get the following error

---

Transaction check error:
  file /usr/lib64/gstreamer-1.0/libgstdtmf.so from install of gstreamer1-plugins-good-1.4.5-2.el7.x86_64 conflicts with file from package gstreamer1-plugins-bad-free-1.0.7-4.el7.x86_64

---
Comment 3 Fedora Update System 2015-12-02 01:08:33 EST
gstreamer1-vaapi-0.6.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cf1220cabc
Comment 4 Fedora Update System 2015-12-02 23:20:33 EST
gstreamer1-vaapi-0.6.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update gstreamer1-vaapi'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cf1220cabc
Comment 5 Fedora Update System 2015-12-18 02:25:18 EST
gstreamer1-vaapi-0.6.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.