Bug 1285136 - SELinux is preventing /usr/sbin/console-kit-daemon from 'write' accesses on the directory /var/lib/dbus.
SELinux is preventing /usr/sbin/console-kit-daemon from 'write' accesses on t...
Status: CLOSED DUPLICATE of bug 1126142
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
23
i686 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
abrt_hash:133e7215eeadcd7d83fdecf9151...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 21:26 EST by Al Dunsmuir
Modified: 2015-11-25 04:36 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 04:36:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Al Dunsmuir 2015-11-24 21:26:54 EST
Description of problem:
Problem occurs on x86 Mate at logon..
SELinux is preventing /usr/sbin/console-kit-daemon from 'write' accesses on the directory /var/lib/dbus.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that console-kit-daemon should be allowed write access on the dbus directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep console-kit-dae /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:consolekit_t:s0
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                /var/lib/dbus [ dir ]
Source                        console-kit-dae
Source Path                   /usr/sbin/console-kit-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ConsoleKit-0.4.5-9.fc21.i686
Target RPM Packages           dbus-1.10.4-1.fc23.i686
Policy RPM                    selinux-policy-3.13.1-154.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.6-300.fc23.i686+PAE #1 SMP Tue
                              Nov 10 19:55:26 UTC 2015 i686 i686
Alert Count                   7
First Seen                    2015-11-12 06:40:19 EST
Last Seen                     2015-11-24 21:18:12 EST
Local ID                      f3443bae-9eb2-4506-bd0d-088d5fcb91d7

Raw Audit Messages
type=AVC msg=audit(1448417892.740:515): avc:  denied  { write } for  pid=1428 comm="console-kit-dae" name="dbus" dev="sda5" ino=2357639 scontext=system_u:system_r:consolekit_t:s0 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=dir permissive=0


type=SYSCALL msg=audit(1448417892.740:515): arch=i386 syscall=open success=no exit=EACCES a0=915b510 a1=c1 a2=1a4 a3=bf833b1c items=0 ppid=1 pid=1428 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=console-kit-dae exe=/usr/sbin/console-kit-daemon subj=system_u:system_r:consolekit_t:s0 key=(null)

Hash: console-kit-dae,consolekit_t,system_dbusd_var_lib_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-154.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.6-300.fc23.i686+PAE
type:           libreport

Potential duplicate: bug 1126142
Comment 1 Lukas Vrabec 2015-11-25 04:36:43 EST

*** This bug has been marked as a duplicate of bug 1126142 ***

Note You need to log in before you can comment on or make changes to this bug.