Bug 1285165 - Items placed in desktop folder under wayland do not show on the desktop
Items placed in desktop folder under wayland do not show on the desktop
Status: CLOSED DUPLICATE of bug 1280195
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-11-25 01:31 EST by Leslie Satenstein
Modified: 2016-11-30 16:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 06:23:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2015-11-25 01:31:19 EST
Description of problem:

Items placed in desktop folder under wayland do not show on the desktop 


Version-Release number of selected component (if applicable):

Gnome Wayland

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

No icons on desktop when an item is stored in ~/Desktop

Expected results:

Item to show on the desktop, as it does with Gnome classic 
and Gnome Standard (X11)

Additional info:

Tweak setting to show ~ icon and trash also not being presented.

Requested
Comment 1 Kamil Páral 2015-12-08 06:23:01 EST

*** This bug has been marked as a duplicate of bug 1280195 ***
Comment 2 Jia Yuan Lo 2016-11-24 00:25:49 EST
I don't think this should be categorised as duplicate for nautilus as this is in fact gnome-shell problem on Wayland

Even without gnome-tweak-tool
One can use dconf-editor or use gsettings command in Terminal

gsettings set org.gnome.desktop.background show-desktop-icons true

which is exactly what gnome-tweak-tool GUI does when you flip ON to show Desktop icons

Note that log off and then login under GNOME on X11, the Desktop icons are there

Back to GNOME on Wayland, nope.
Comment 3 Felix Schwarz 2016-11-30 16:30:01 EST
(In reply to Jia Yuan Lo from comment #2)
> I don't think this should be categorised as duplicate for nautilus as this
> is in fact gnome-shell problem on Wayland (...)

While it seem strange the "nautilus" application is responsible for displaying the desktop icons so the resolution here is technically correct (even though I miss desktop icons personally).

Note You need to log in before you can comment on or make changes to this bug.