Bug 1285173 - Create doesn't remember flags it is opened with
Create doesn't remember flags it is opened with
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 1285174
  Show dependency treegraph
 
Reported: 2015-11-25 02:09 EST by Pranith Kumar K
Modified: 2016-06-16 09:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1285174 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:46:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2015-11-25 02:09:13 EST
Description of problem:

We found in code review that create fop is not remembering the flags it comes with. This will lead to failures of the fops once there is a disconnect and reconnect.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-11-25 02:16:41 EST
REVIEW: http://review.gluster.org/12739 (cluster/afr: Remember flags sent by create fop) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2015-11-26 04:59:27 EST
COMMIT: http://review.gluster.org/12739 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 789803ce16409a1f9ce84c0f9a60e68bd630380e
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Nov 25 12:31:25 2015 +0530

    cluster/afr: Remember flags sent by create fop
    
    Problem:
    In create fop, afr doesn't remember the flags. When afr has to perform
    fixing of the fd that needs to be opened on other bricks because the brick
    was down at the time of create, the flags with which it needs to send open
    are not present.
    
    Fix:
    Remember the flags in the fd_ctx.
    
    Thanks to Nitya for showing us the problem in re-open with the flags.
    
    Change-Id: I8ce1eb50c35fc0722cfc25cb4b6d234ef56180e5
    BUG: 1285173
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/12739
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Niels de Vos 2016-06-16 09:46:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.