Bug 1285187 - --restore-disk-image no longer opens disk image restore view
--restore-disk-image no longer opens disk image restore view
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-disk-utility (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 03:20 EST by Ville Skyttä
Modified: 2015-12-01 12:51 EST (History)
4 users (show)

See Also:
Fixed In Version: gnome-disk-utility-3.18.3.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 12:51:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2015-11-25 03:20:46 EST
gnome-disks --restore-disk-image foo.iso no longer opens the disk image restoration dialog, it just opens the gnome-disks UI, and consequently the open with Disk Image Writer option in Nautilus doesn't work as it should.

Looking at the code, it looks like it should also be checking that the file given as argument should be a regular file, but that doesn't happen either; if I pass let's say --restore-disk-image /tmp there are no complaints anywhere and the main UI just opens.

This used to work in F-22.

$ rpm -q gnome-disk-utility
gnome-disk-utility-3.18.2-1.fc23.x86_64
Comment 1 Ville Skyttä 2015-11-25 04:36:27 EST
Checking some earlier builds, this broke somewhere between 3.16.2 and 3.17.2.

Looks like the combination of G_OPTION_ARG_FILENAME and the corresponding g_variant_dict_lookup call for restore-disk-image doesn't work. If I change restore-disk-image to G_OPTION_ARG_STRING instead, things work again. So this commit by Matthias is probably the culprit:

https://git.gnome.org/browse/gnome-disk-utility/commit/?id=7c36385393d3f2a8b7e9837519a50cb97514860a
Comment 3 Michael Catanzaro 2015-11-26 23:01:03 EST
Thanks for the report and for the fix!
Comment 4 Fedora Update System 2015-11-27 18:16:52 EST
gnome-disk-utility-3.18.3.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-87a311850d
Comment 5 Fedora Update System 2015-11-28 21:23:12 EST
gnome-disk-utility-3.18.3.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-disk-utility'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-87a311850d
Comment 6 Fedora Update System 2015-12-01 12:51:44 EST
gnome-disk-utility-3.18.3.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.