Bug 1285196 - Dist-geo-rep : checkpoint doesn't reach even though all the files have been synced through hybrid crawl.
Summary: Dist-geo-rep : checkpoint doesn't reach even though all the files have been s...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication   
(Show other bugs)
Version: 3.1
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
: RHGS 3.1.3
Assignee: Aravinda VK
QA Contact: Rahul Hinduja
URL:
Whiteboard: checkpoint
Keywords: ZStream
Depends On: 1044645 1064309
Blocks: 1202842 1223636 1247536 1279306 1299184
TreeView+ depends on / blocked
 
Reported: 2015-11-25 08:38 UTC by Aravinda VK
Modified: 2016-06-23 04:57 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.7.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1044645
Environment:
Last Closed: 2016-06-23 04:57:21 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1240 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 Update 3 2016-06-23 08:51:28 UTC

Comment 2 Aravinda VK 2016-01-13 07:34:59 UTC
Upstream Patch sent
http://review.gluster.org/#/c/11771/

Comment 4 Aravinda VK 2016-03-23 06:22:56 UTC
Patch for this bug is available in rhgs-3.1.3 branch as part of rebase from upstream release-3.7.9.

Comment 6 Rahul Hinduja 2016-04-12 11:52:58 UTC
Verified with the build: glusterfs-3.7.9-1

In the following scenario: 
1. Files were present before the geo-replication session and synced through Hybrid Crawl. The status detail shows checkpoint completion
2. changedetector is set as xsync and files created. Once the files are synced, the status detail shows the checkpoint completion as YES.

Moving the bug to verified state.

Comment 9 errata-xmlrpc 2016-06-23 04:57:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240


Note You need to log in before you can comment on or make changes to this bug.