Bug 1285235 - 3.10.0-327.el7 crashes on boot on HP N54L
3.10.0-327.el7 crashes on boot on HP N54L
Status: CLOSED DUPLICATE of bug 1265283
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: 7.3
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
: 1295056 (view as bug list)
Depends On:
Blocks: 1203710
  Show dependency treegraph
 
Reported: 2015-11-25 04:30 EST by Pablo Iranzo Gómez
Modified: 2016-01-27 07:44 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 09:00:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of iLO capture (306.83 KB, image/png)
2015-11-25 04:31 EST, Pablo Iranzo Gómez
no flags Details
sosreport (6.31 MB, application/x-xz)
2015-11-25 06:23 EST, Javier Ramirez
no flags Details
Capture during 7.2 install from USB (376.44 KB, image/png)
2015-11-25 09:02 EST, Gary Smith
no flags Details

  None (edit)
Description Pablo Iranzo Gómez 2015-11-25 04:30:53 EST
Description of problem:

After updating system to 7.2 with kernel 3.10.0-327.el7 system crashes on boot.

Version-Release number of selected component (if applicable):

Kernel 3.10.0-327.el7

How reproducible:

Upgrade kernel to 3.10.0-327.el7, reboot system, crash appears

Actual results:
System crashes on boot


Expected results:
System boots properly


Additional info:

Booting with previous kernel makes the system boot again
Comment 1 Pablo Iranzo Gómez 2015-11-25 04:31 EST
Created attachment 1098640 [details]
Image of iLO capture
Comment 2 Pablo Iranzo Gómez 2015-11-25 05:19:49 EST
I'm unable to get sysrq working either via console or via ipmitool sol access

A colleague has same problem.

From the OS I can trigger crash and it works.

Any hint?
Comment 4 Javier Ramirez 2015-11-25 06:22:10 EST
Same happening in my AMD Turion(tm) II Neo N54L Dual-Core Processor, I have no ILO so no screenshots of the panic, but I want to mention that is happening so early in the boot process that kdump nor sysrq works. I'm attaching a sosreport just in case.
Comment 5 Javier Ramirez 2015-11-25 06:23 EST
Created attachment 1098745 [details]
sosreport
Comment 6 Gary Smith 2015-11-25 09:02 EST
Created attachment 1098825 [details]
Capture during 7.2 install from USB

I tried to install 7.2 via USB stick on my N54L and got the attached backtrace as soon as it booted, which is different from comment#1
Comment 8 Prarit Bhargava 2015-12-02 08:04:34 EST
Can you try booting with the kernel parameter 

initcall_blacklist=clocksource_done_booting

?

P.
Comment 10 Julio Entrena Perez 2015-12-02 08:57:09 EST
(In reply to Prarit Bhargava from comment #8)
> Can you try booting with the kernel parameter 
> 
> initcall_blacklist=clocksource_done_booting

Yep, that option allows it to boot up successfully.
Comment 11 Prarit Bhargava 2015-12-02 09:00:00 EST
(In reply to Julio Entrena Perez from comment #10)
> (In reply to Prarit Bhargava from comment #8)
> > Can you try booting with the kernel parameter 
> > 
> > initcall_blacklist=clocksource_done_booting
> 
> Yep, that option allows it to boot up successfully.

\o/ :)

Okay, a fix for this was put into the z-stream release for RHEL7.2.  Unfortunately you'll have to install with this option and then immediately upgrade the kernel to the RHEL7.2.z release.

I'm closing this bug as a DUPLICATE of BZ 1265283.

P.

*** This bug has been marked as a duplicate of bug 1265283 ***
Comment 12 Prarit Bhargava 2015-12-02 09:02:17 EST
(In reply to Javier Ramirez from comment #4)
> Same happening in my AMD Turion(tm) II Neo N54L Dual-Core Processor, I have
> no ILO so no screenshots of the panic, but I want to mention that is
> happening so early in the boot process that kdump nor sysrq works. I'm
> attaching a sosreport just in case.

FWIW ... for some odd reason the AMD Turion processors seem to hit this more often than any other processor.  I'm not sure why that is, but it has been resolved in BZ 1265283.

P.
Comment 13 Julio Entrena Perez 2015-12-02 09:02:59 EST
Thanks prarit++
Comment 14 Fabian Arrotin 2015-12-15 04:07:18 EST
Just to add to the bug report that initcall_blacklist=clocksource_done_booting kernel parameter also solves the same issue on the following lenovo thinkpad : 

 Manufacturer: LENOVO
 Product Name: 25453PG
 Version: ThinkPad Edge
 Processor model name: AMD Athlon(tm) II Neo K345 Dual-Core Processor
Comment 15 Prarit Bhargava 2016-01-03 11:51:32 EST
*** Bug 1295056 has been marked as a duplicate of this bug. ***
Comment 16 Tru Huynh 2016-01-27 07:34:42 EST
from the CentOS bugs entry: https://bugs.centos.org/view.php?id=9860#c25506

<quote>On my HP N40L, that workaround does let it boot, but I don't really trust this. For instance, I found that reading sysfs current_clocksource crashed the system, even as an unprivileged user!

  $ cat /sys/devices/system/clocksource/clocksource0/current_clocksource

The crash is easy to understand -- clocksource_done_booting() is supposed to set pointer curr_clocksource, and sysfs_show_current_clocksources() dereferences it. 
</quote>
Comment 17 Prarit Bhargava 2016-01-27 07:44:35 EST
(In reply to Tru Huynh from comment #16)
> from the CentOS bugs entry: https://bugs.centos.org/view.php?id=9860#c25506
> 
> <quote>On my HP N40L, that workaround does let it boot, but I don't really
> trust this. For instance, I found that reading sysfs current_clocksource
> crashed the system, even as an unprivileged user!
> 
>   $ cat /sys/devices/system/clocksource/clocksource0/current_clocksource
> 
> The crash is easy to understand -- clocksource_done_booting() is supposed to
> set pointer curr_clocksource, and sysfs_show_current_clocksources()
> dereferences it. 
> </quote>

The workaround is only meant to get you through the initial install.  After the installation, upgrade to the latest functioning kernel, and then reboot.  A permanent fix for this issue will be available at some point in z-stream.  Please contact your support person for further details.

P.

Note You need to log in before you can comment on or make changes to this bug.