Bug 1285276 - After closing task it will re-appear again.
Summary: After closing task it will re-appear again.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Tasks Plugin
Version: 6.1.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Adam Ruzicka
QA Contact: Og Maciel
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1317008
TreeView+ depends on / blocked
 
Reported: 2015-11-25 10:39 UTC by jnikolak
Modified: 2019-11-14 07:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:20:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description jnikolak 2015-11-25 10:39:07 UTC
Reproduce:

Go to Monitor -> Tasks -> Task

After pressing x, the task will close then re-appear.

Customer running: 
OS X 10.11

Version 46.0.2490.86 (64-bit) - Chrome
Firefox 42

Comment 3 jnikolak 2016-01-11 04:26:45 UTC
From Duplicate bug 1203050)  

I've just ran into this in 6.1.5.

Syncing a lot of repos during the night, and when I came into work this morning none has finished, they all just stay at pending, and no new task will run, just get put to pending.

Comment 4 Adam Ruzicka 2016-02-18 11:07:39 UTC
Created redmine issue http://projects.theforeman.org/issues/13787 from this bug

Comment 5 Ivan Necas 2016-03-03 15:49:19 UTC
Released in foreman-tasks 0.7.15

Comment 7 Tazim Kolhar 2016-03-22 08:06:54 UTC
Hi,

   please provide clarification for Verification Steps.

   The below steps looks incomplete:   

   Go to Monitor -> Tasks -> Task

   After pressing x, the task will close then re-appear.

   Customer running: 
   OS X 10.11


Thanks and Regards,
Tazim

Comment 8 Stuart Auchterlonie 2016-03-22 09:30:55 UTC
There is a timing related element to this.

You need to close the popup window just prior to the
timer based auto reload of the page.

If you close the popup well in advance of the auto reload
then you will not see this issue.


Regards
Stuart

Comment 9 Og Maciel 2016-03-24 15:20:53 UTC
Verified on Satellite 6.2.0 SNAP 5.1

I followed the same steps described in the original issue and looked at both stopped tasks and running tasks (such as synchronization of a repo). I was able to select the task, which brings up a detailed tab, and close this tab by clicking the 'x' icon on the upper right corner of the tab. Once closed, the tab did not re-open.

Comment 11 jnikolak 2016-05-16 02:41:34 UTC
Happy to close this bug, if the issue is gone in new version, I will re-open if I find it.

Comment 13 errata-xmlrpc 2016-07-27 09:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.