Bug 1285280 - Self-Service UI: Counting on left bar includes un-assigned Catalog Items but not on the main body part
Self-Service UI: Counting on left bar includes un-assigned Catalog Items but ...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Aparna Karve
Dave Johnson
:
Depends On:
Blocks: 1289652
  Show dependency treegraph
 
Reported: 2015-11-25 05:51 EST by Loic Avenel
Modified: 2015-12-14 13:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289652 (view as bug list)
Environment:
Last Closed: 2015-12-14 13:26:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshots showing different numbers (144.67 KB, image/png)
2015-11-25 05:51 EST, Loic Avenel
no flags Details

  None (edit)
Description Loic Avenel 2015-11-25 05:51:44 EST
Created attachment 1098700 [details]
Snapshots showing different numbers

Description of problem: There are 6 Services (Catalog Item & Bundle) and 2 Catalog Items that are un-assigned (part of a Bundle), in Self Service, left bar shows 8 items while main body of the UI 6
NB: I am logged as Admin


Version-Release number of selected component (if applicable):


How reproducible: every time


Steps to Reproduce:
1. Create un-assigned Items
2. Log to self-Service UI
3.

Actual results: Not the same number of Items in left bar and Body


Expected results: same number


Additional info:
Comment 2 Loic Avenel 2015-11-25 06:12:58 EST
Version is 4.0 RC1
Comment 3 Aparna Karve 2015-12-09 19:31:20 EST
Hi Loic,

Does the count fix itself the next time you login ?

What I noticed was, the SSUI updates the count on the sidebar every minute or so, and while it does that, it does not update the count on the main body.
However, when you login the next time, the count on the sidebar and the main body match.

Thanks,
Aparna
Comment 4 Loic Avenel 2015-12-11 11:18:54 EST
Hi Aparna, Sorry for the late answer. In my case on RC1, it always wrong even when I log again.

Regards
Loic
Comment 6 Loic Avenel 2015-12-11 13:54:21 EST
It is running on my laptop, you cannot get access from outside, we can do the opposite, if you have a running appliance I can connect I will reproduce the issue...
Comment 7 Aparna Karve 2015-12-11 14:25:31 EST
hmm, unfortunately I'm running on my laptop too.
Maybe I can talk to QE and get hold of an appliance.
Comment 8 Loic Avenel 2015-12-14 10:06:29 EST
Hi Aparna,

   I gave a tray with 4.0 GA and I cannot reproduce the issue then I think it was 4.0 RC1 related.

Regards
Loic

Note You need to log in before you can comment on or make changes to this bug.