Bug 1285284 - Self-Service UI: browser refresh always bring back to Login page
Self-Service UI: browser refresh always bring back to Login page
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Martin Hradil
Niyaz Akhtar Ansari
:
Depends On:
Blocks: 1289656
  Show dependency treegraph
 
Reported: 2015-11-25 06:10 EST by Loic Avenel
Modified: 2016-06-29 11:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289656 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:11:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Loic Avenel 2015-11-25 06:10:11 EST
Description of problem: In Self Service UI when refreshing Internet Browser, we are logged out and send back to login page


Version-Release number of selected component (if applicable):

4.0 RC1


How reproducible: Every time


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 CFME Bot 2016-01-06 14:17:20 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b9e97e7d297d781a6eb75ed6d08b936ec1671782

commit b9e97e7d297d781a6eb75ed6d08b936ec1671782
Merge: bca1ebf 05796f5
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Jan 6 14:13:55 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Jan 6 14:13:55 2016 -0500

    Merge branch 'bz1289656-ssui-token-55' into '5.5.z'
    
    SSUI - authentication related changes
    
    Changes in SSUI:
    
       * when you push reload, previously it would just go to the login screen, now it goes to the same screen as before (but any state not bound to the url (and authentication token) is lost)
       * token is remembered in sessionStorage
       * logged in user info is no longer retrieved from the user collection on login, but from the /api/ .identity field, on reload or login - added Session.loadUser()
       * the full name of the currently logged in user is shown by the icon, not only on hover
       * the autorefresh requests are now sent with a new X-Auth-Skip-Token-Renewal: true header, but anything triggered by user action doesn't have it
       * removed broken expiresOn logic from client (was from before the api started resetting token expiration), we now rely on 401 responses for that
       * the "session timed out" notification is only shown once when redirected to the login screen, previously it would create a new one for each failing request (so typically 3 at once)
    
    Changes in API:
    
       * do not reset token expiration if X-Auth-Skip-Token-Renewal is sent (with the value of "true")
    
    Changes in tooling:
    
       * removed the `disallowTrailingComma` rule for jscs, we're no longer targetting old-IE so there's no longer reason for that
       * extended line lenght limit to 140 characters (from 120) - related: jscs-dev/node-jscs#2032
    
    Note:
    
       * the bower.json / index.html churn is caused by current version of bower sorting the dependencies - the only real change is adding ngStorage
    
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1285284
    
    ---
    
    5.5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1289656
    
    clean cherry-pick except for spa_ui/self_service/.jscsrc, because 5.5 is using jscs 1.11 instead of 2.7
    
    See merge request !678

 app/controllers/api_controller/authentication.rb   |  6 ++++-
 spa_ui/self_service/.jscsrc                        |  3 +--
 spa_ui/self_service/.jshintrc                      |  2 +-
 spa_ui/self_service/bower.json                     | 25 +++++++++----------
 spa_ui/self_service/client/app/app.module.js       |  2 +-
 .../app/components/navigation/_navigation.sass     |  5 ++++
 .../app/components/navigation/header-nav.html      |  7 +++---
 .../client/app/config/authorization.config.js      | 28 +++++++++++++++++-----
 .../client/app/config/navigation.config.js         | 28 +++++++++++++++++-----
 .../app/resources/collections-api.factory.js       | 25 +++++++++++++++----
 .../client/app/services/services.module.js         |  4 +++-
 .../client/app/services/session.service.js         | 20 +++++++++++-----
 .../app/states/dashboard/dashboard.state.spec.js   |  1 -
 .../client/app/states/login/login.state.js         | 24 +++++++------------
 spa_ui/self_service/client/index.html              | 27 +++++++++++----------
 15 files changed, 133 insertions(+), 74 deletions(-)
Comment 5 Niyaz Akhtar Ansari 2016-04-18 03:32:48 EDT
Self-Service UI: browser refresh successful 

Verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 7 errata-xmlrpc 2016-06-29 11:11:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.