Bug 1285288 - Better indication of arbiter brick presence in a volume.
Better indication of arbiter brick presence in a volume.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: arbiter (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ravishankar N
:
Depends On: 1283570
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 06:15 EST by Ravishankar N
Modified: 2016-06-16 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283570
Environment:
Last Closed: 2016-06-16 09:46:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-11-25 06:15:48 EST
+++ This bug was initially created as a clone of Bug #1283570 +++

Description of problem:

Currently there's no clear indication of volume being in an arbiter setup in the "gluster volume info" output. There's a change addressing that in 

http://review.gluster.com/#/c/12479/

but it still is a bit cryptic.

Version-Release number of selected component (if applicable):

arbiter in GlusterFS 3.7.6 with a patch applied from http://review.gluster.com/#/c/12479/

How reproducible:

Issue "gluster volume info test-volume" where "test-volume" is a volume with an arbiter brick.


Actual results:

Volume Name: system_mail1
Type: Replicate
Volume ID: 7a49e1a2-01d3-4fe7-ac61-173757396250
Status: Started
Number of Bricks: 1 x (2 + 1) = 3
Transport-type: tcp
Bricks:
Brick1: cluster-rep:/GFS/system/mail1
Brick2: mail-rep:/GFS/system/mail1
Brick3: web-rep:/GFS/system/mail1
Options Reconfigured:
performance.readdir-ahead: on
cluster.server-quorum-ratio: 51%


Expected results:

Volume Name: system_mail1
Type: Replicate
Volume ID: 7a49e1a2-01d3-4fe7-ac61-173757396250
Status: Started
Number of Bricks: 1 x (2 + 1) = 3
Transport-type: tcp
Bricks:
Brick1: cluster-rep:/GFS/system/mail1
Brick2: mail-rep:/GFS/system/mail1
Brick3: web-rep:/GFS/system/mail1 (arbiter)
Options Reconfigured:
performance.readdir-ahead: on
cluster.server-quorum-ratio: 51%
Comment 1 Vijay Bellur 2015-11-25 06:16:42 EST
REVIEW: http://review.gluster.org/12747 (cli: Indicate which brick of the replica is the arbiter) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2015-11-26 02:26:01 EST
COMMIT: http://review.gluster.org/12747 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 20588e53774f1f16e4e9e25481b785f02231c485
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Nov 25 16:42:20 2015 +0530

    cli: Indicate which brick of the replica is the arbiter
    
    Enhances the cli output for arbiter volumes as requested in the BZ.
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    
    Change-Id: I28cc34d7d19def043d54291cede25a58dbcc5051
    BUG: 1285288
    Reviewed-on: http://review.gluster.org/12747
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:46:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.