Bug 1285291 - all packages listed when listing errata
Summary: all packages listed when listing errata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.1.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-25 11:19 UTC by jnikolak
Modified: 2019-09-25 21:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:20:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
errata_bulk_actions (156.30 KB, image/png)
2015-11-25 11:19 UTC, jnikolak
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description jnikolak 2015-11-25 11:19:18 UTC
Created attachment 1098743 [details]
errata_bulk_actions

Reproduce:

Go to host -> content host
Select multiple servers then go to bulk actions
Click Errata

A new page will appear and you will see the text like following
Showing 80 of 747 (785979 Total)

This appears to be listing all packages are available, but in reality it should only list the errata that is available to the two servers selected.

Customer tried then to use host collections, 
adding only rhel 6 servers, but received the same issue.


screenshot attached

Comment 2 Walden Raines 2016-02-24 17:47:39 UTC
Created redmine issue http://projects.theforeman.org/issues/13886 from this bug

Comment 3 Walden Raines 2016-02-24 17:54:08 UTC
PR: https://github.com/Katello/katello/pull/5810

Comment 4 Bryan Kearney 2016-02-24 19:05:15 UTC
Upstream bug component is Content Management

Comment 5 Bryan Kearney 2016-02-24 23:05:06 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13886 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|3ca780da6e81f597e5979024f046915ccb9aa2fd.

Comment 8 jcallaha 2016-04-04 17:11:57 UTC
Verified in Satellite 6.2 Beta Snap 6 Compose 1.

Only applicable errata are displayed, instead of all packages.

Comment 10 errata-xmlrpc 2016-07-27 09:20:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.