Bug 1285306 - Unresolved dependencies on ctdb-4.2.4-7.el6rhs.x86_64
Unresolved dependencies on ctdb-4.2.4-7.el6rhs.x86_64
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Linux
medium Severity high
: ---
: RHGS 3.1.2
Assigned To: Jose A. Rivera
surabhi
: ZStream
Depends On: 1285281
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-11-25 06:39 EST by Sreenath G
Modified: 2016-03-01 00:58 EST (History)
7 users (show)

See Also:
Fixed In Version: samba-4.2.4-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:58:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sreenath G 2015-11-25 06:39:08 EST
Description of problem:

ctdb-4.2.4-7.el6rhs.x86_64 from new samba build (samba-4.2.4-7.el6rhs) has an install dependency on "systemd-units" and "procps-ng" which is not satisfied. Because of this the puddle and ISO compose is blocked.

Version-Release number of selected component (if applicable):
4.2.4-7.el6rhs


How reproducible:
By running the puddle again or repo-closure script.


Steps to Reproduce:
1.
2.
3.

Actual results:

*** package: ctdb-4.2.4-7.el6rhs.x86_64 from file:///mnt/redhat/rel-eng/RHGS/3.1-u2-RHEL-6/2015-11-25.1/RH-Gluster-3-Samba-/x86_64/os

unresolved deps: 
***      systemd-units
***      systemd-units
***      procps-ng


Expected results:

All the install dependencies should be satisfied ie present in brew tag inheritance.

Additional info:
Comment 1 Jose A. Rivera 2015-11-27 08:43:27 EST
New build is up with the appropriate changes and attached to errata:

https://brewweb.devel.redhat.com/buildinfo?buildID=468103
Comment 3 surabhi 2015-12-02 03:36:44 EST
The install of ctdb package is successfull on RHEL6 with the new build.
The ctdb install happens successfully without any dependency issues.

Also as mentioned in #C2 Puddle has been generated successfully for samba/ctdb for RHEL6.
Marking the BZ verified with following build :
Build info:
samba-4.2.4-8.el6rhs.x86_64
ctdb-4.2.4-8.el6rhs.x86_64
Comment 5 errata-xmlrpc 2016-03-01 00:58:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.