Bug 1285316 - metadata_expire=never does not work since Fedora 23
metadata_expire=never does not work since Fedora 23
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 06:53 EST by Michael S. Tsirkin
Modified: 2016-01-05 05:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 08:58:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael S. Tsirkin 2015-11-25 06:53:12 EST
Description of problem:
I have metadata_expire=never in both dnf.conf and
yum.conf. Neither seems to have the desired effect.
Under Fedora 22, the effect is that dnf
can function much like apt:
dnf makecache downloads data, dnf update
updates it, dnf install downloads and install package
all without bothering to touch metadata.


Version-Release number of selected component (if applicable):
dnf-1.1.4-1.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1. set  metadata_expire=never 
2. run dnf makecache
3. wait a day or two

Actual results:
dnf starts loading metadata (I'm guessing - it's showing
progress bar) from all its sources.


Expected results:
dnf update uses cached metadata since it never expires

Additional info:
this is a regression: worked fine under Fedora 22.
Comment 1 Honza Silhan 2016-01-04 08:58:42 EST

*** This bug has been marked as a duplicate of bug 1293910 ***
Comment 2 Jaroslav Mracek 2016-01-05 05:52:09 EST
I have try to reproduce and I have found, that in this case it is probably not a bug. I think that you have metadata_expire=some_number in .repo file that describe repository. If this option is present, it overwrites options in dnf.conf file. Please if this is not your case, feel free to reopen the bug report.

Note You need to log in before you can comment on or make changes to this bug.