Bug 1285335 - [Tier]: Stopping and Starting tier volume triggers fixing layout which fails on local host
[Tier]: Stopping and Starting tier volume triggers fixing layout which fails ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: ZStream
Depends On: 1276245 1284372
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-11-25 07:21 EST by Mohammed Rafi KC
Modified: 2016-04-19 03:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284372
Environment:
Last Closed: 2016-04-19 03:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-25 07:21:53 EST
REVIEW: http://review.gluster.org/12749 (glusterd: Change volume start into v3 framework) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-11-25 23:44:30 EST
COMMIT: http://review.gluster.org/12749 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 27ff5e14e2577c671f5890ec845ec04e8046ec52
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Nov 23 12:05:54 2015 +0530

    glusterd: Change volume start into v3 framework
    
    As part of volume start, if the volume is of tier type
    then we need to start tiering daemon also. But before
    starting tier daemon all the bricks should be started.
    
    So by changing volume start into v3 framework, we can
    do tier start in post validate phase
    
    Backport of>
    >Change-Id: If921067f4739e6b9a3239fc5717696eaf382c22a
    >BUG: 1284372
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/12718
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    (cherry picked from commit 03f731a8b32db7bef7c5e9ffc11c16f670ffe960)
    
    Change-Id: Id6fd5555d16d605eb344efd9b9e261644469ecef
    BUG: 1285335
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12749
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Kaushal 2016-04-19 03:49:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.