Bug 128535 - .Package vim-enhanced needs /usr/lib/perl5/5.8.4/i386-linux-thread-multi, this is not available.
.Package vim-enhanced needs /usr/lib/perl5/5.8.4/i386-linux-thread-multi, thi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-24 15:50 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 08:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-07-24 15:50:25 EDT
Description of problem:

  Seems to be a directory dependence on a particular version of perl

  This package dependency popped up before, that time it depended on
version 5.8.3 of perl..

Version-Release number of selected component (if applicable):

[root@hoho2 user1]# rpm -q vim-enhanced
vim-enhanced-6.3.014-1

  This is version installed. yum is apparently trying to install an
upgraded version of vim-enhanced.

How reproducible:

  Has been there for about a week now. Popped up before with a
dependency on a previous version of perl

Steps to Reproduce:
1.yum -y --exclude=\*debuginfo\* install \*
2.
3.
  
Actual results:

[root@hoho2 user1]# yum -y --exclude=\*debuginfo\* install \*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
kernel-smp is installed and is the latest version.
openssl is installed and is the latest version.
glibc is installed and is the latest version.
kernel is installed and is the latest version.
Resolving dependencies
.Package vim-enhanced needs
/usr/lib/perl5/5.8.4/i386-linux-thread-multi, this is not available.


--- the rest of the output does not pertain to vim-enhanced, but
--- it has been a problem for a few weeks..

Package katana-build needs katana = 1.0.4-4, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package xerces-j needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package ecj needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package junit needs katana, this is not available.
Package jaf needs katana, this is not available.
Package cup needs katana, this is not available.
Package jlex needs katana, this is not available.
[root@hoho2 user1]#




Expected results:


Additional info:[root@hoho2 user1]# rpm -q vim
package vim is not installed

[root@hoho2 user1]# rpm -q vim-enhanced
vim-enhanced-6.3.014-1

[root@hoho2 user1]# which vim
/usr/bin/vim

[root@hoho2 user1]# vim --version
VIM - Vi IMproved 6.3 (2004 June 7, compiled Jul 22 2004 05:03:23)
Included patches: 1-14
Compiled by <bugzilla@redhat.com>
Huge version without GUI.  Features included (+) or not (-):
+arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset
+cindent
-clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info
+comments
+cryptv +cscope +dialog_con +diff +digraphs -dnd -ebcdic +emacs_tags +eval
+ex_extra +extra_search +farsi +file_in_path +find_in_path +folding
-footer
+fork() +gettext -hangul_input +iconv +insert_expand +jumplist +keymap
+langmap
 +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
+modify_fname +mouse -mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm
+mouse_netterm +mouse_xterm +multi_byte +multi_lang -netbeans_intg
-osfiletype
+path_extra +perl +postscript +printer +python +quickfix +rightleft -ruby
+scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax
+tag_binary +tag_old_static -tag_any_white -tcl +terminfo +termresponse
+textobjects +title -toolbar +user_commands +vertsplit +virtualedit
+visual
+visualextra +viminfo +vreplace +wildignore +wildmenu +windows
+writebackup
-X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save
   system vimrc file: "/etc/vimrc"
     user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
  fall-back for $VIM: "/usr/share/vim"
Compilation: i386-redhat-linux-gcc -c -I. -Iproto -DHAVE_CONFIG_H    
-O2 -g -pipe -m32 -march=i386 -mtune=pentium4 -D_GNU_SOURCE
-D_FILE_OFFSET_BITS=64   -D_REENTRANT -D_GNU_SOURCE
-DTHREADS_HAVE_PIDS -DDEBUGGING  -I/usr/local/include
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm 
-I/usr/lib/perl5/5.8.4/i386-linux-thread-multi/CORE 
-I/usr/include/python2.3 -pthread
Linking: i386-redhat-linux-gcc   -Wl,-E
-Wl,-rpath,/usr/lib/perl5/5.8.4/i386-linux-thread-multi/CORE  
-L/usr/local/lib -o vim       -lncurses -lselinux  -lacl -lgpm -Wl,-E
-Wl,-rpath,/usr/lib/perl5/5.8.4/i386-linux-thread-multi/CORE 
-L/usr/local/lib
/usr/lib/perl5/5.8.4/i386-linux-thread-multi/auto/DynaLoader/DynaLoader.a
-L/usr/lib/perl5/5.8.4/i386-linux-thread-multi/CORE -lperl -lutil -lc
-L/usr/lib/python2.3/config -lpython2.3 -lutil -lm -Xlinker
-export-dynamic
[root@hoho2 user1]#
Comment 1 Arenas Belon, Carlo Marcelo 2004-07-24 23:24:39 EDT
a compile time delpendency is being used on the SPEC file for perl,
and therefore it is different based on the architecture being used.

on x86_64 (from the fedora core3 test1) while trying to update perl :

/usr/lib64/perl5/5.8.4/x86_64-linux-thread-multi is needed by
(installed) vim-enhanced-6.3.014-1

where 5.8.4 was the version installed on the system where the
vim-enhanced package was prepared.

changing on the SPEC the following line :

Requires:  %(perl -le 'use Config;print $Config{archlibexp}')

for :

Requires: perl

fixes the problem, and provides the right install time dependency.
  
Comment 2 Arenas Belon, Carlo Marcelo 2004-07-25 01:35:18 EDT
as detailed on bug 128524, a patch to configure.in would be also
required in order to fix the compiled in dependency for libperl.so.

as well as a way to fix the dynamic linking for libperl.so at runtime,
most likely by adding an /etc/ld.so.conf.d/perl file which adds the
right library to the path of the dynamic linker so it can get loaded
as needed.

this would be also a generic solution to any other package which
depends on this library being found and switching the dependency
tracking for this library to the perl package, where it belongs.
Comment 3 Karsten Hopp 2004-08-02 08:48:33 EDT
Warren added a check for compatible perl versions to the vim specfile.
This should be fixed in the Rawhide versions.

Note You need to log in before you can comment on or make changes to this bug.