Bug 1285360 - RFE: Please optimize repoquery --requires --resolve
RFE: Please optimize repoquery --requires --resolve
Status: CLOSED DUPLICATE of bug 1279538
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1275275
  Show dependency treegraph
 
Reported: 2015-11-25 08:08 EST by Alec Leamas
Modified: 2015-11-26 04:06 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 04:06:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alec Leamas 2015-11-25 08:08:17 EST
Description of problem:

When using e. g., 'dnf repoquery --requires --resolve <package> dnf is seemingly much slower than yum. A simple example on a i5 with 4 MB ram with warm caches:

$ time dnf repoquery -C --resolve --requires python fedora-reviev
[snip]

real	1m59.434s
user	1m58.479s
sys	0m0.968s

$time repoquery -C --resolve --requires python fedora-review
[snip]

real	0m3.010s
user	0m0.571s
sys	0m0.167s

This hits fedora-review, see e. g., bug #1275275. Given the figures, some kind of optimization should be possible (?)
Comment 1 Christian Dersch 2015-11-26 04:06:27 EST
Issue already reported: https://bugzilla.redhat.com/show_bug.cgi?id=1279538

*** This bug has been marked as a duplicate of bug 1279538 ***

Note You need to log in before you can comment on or make changes to this bug.