Bug 1285361 - PackageKit-Qt-0.8.9-2 does not build against PackageKit-1.0.7-5 in RHEL7.2
Summary: PackageKit-Qt-0.8.9-2 does not build against PackageKit-1.0.7-5 in RHEL7.2
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: PackageKit-Qt
Version: epel7
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: epel7aarch64 epel7ppc64le
TreeView+ depends on / blocked
 
Reported: 2015-11-25 13:08 UTC by Menanteau Guy
Modified: 2016-01-03 01:29 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-01-03 01:29:37 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2015-11-25 13:08:45 UTC
Build error on PackageKit-Qt-0.8.9-2 in my epel7 ppc64le environment based on RHEL7.2.
/usr/bin/cmake -E cmake_progress_report /builddir/build/BUILD/packagekit-packagekit-qt/ppc64le-redhat-linux-gnu/CMakeFiles 13
/builddir/build/BUILD/packagekit-packagekit-qt/src/transaction.cpp: In member function 'void PackageKit::Transaction::getDepends(const QStringList&, PackageKit::Transaction::Filters, bool)':
/builddir/build/BUILD/packagekit-packagekit-qt/src/transaction.cpp:488:90: error: 'class TransactionProxy' has no member named 'GetDepends'
...

PackageKit have been updated to 1.0.7-5 in RHEL7.2 and PackageKit-Qt failed now.
I am wondering if PackageKit-Qt should be updated too.

Comment 1 Rex Dieter 2015-11-25 14:02:44 UTC
Wow, 7.2 made a big jump wrt PackageKit, I'll try to look into it, but will likely have to wait until centos 7.2 is available to test it personally.

Comment 2 Fedora Update System 2015-12-07 19:37:44 UTC
apper-0.9.2-3.el7 PackageKit-Qt-0.9.5-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cd80db2d75

Comment 3 Fedora Update System 2015-12-08 07:20:59 UTC
PackageKit-Qt-0.9.5-2.el7, apper-0.9.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update apper PackageKit-Qt'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cd80db2d75

Comment 4 Fedora Update System 2015-12-18 00:15:26 UTC
PackageKit-Qt-0.9.5-2.el7 apper-0.9.2-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cd80db2d75

Comment 5 Fedora Update System 2015-12-18 14:20:35 UTC
PackageKit-Qt-0.9.5-2.el7, apper-0.9.2-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update apper PackageKit-Qt'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cd80db2d75

Comment 6 Fedora Update System 2016-01-03 01:29:34 UTC
PackageKit-Qt-0.9.5-2.el7, apper-0.9.2-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.