Bug 1285364 - [gtk3] [wayland] URLs can't be opened
[gtk3] [wayland] URLs can't be opened
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 08:20 EST by Christian Stadelmann
Modified: 2015-12-24 19:25 EST (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-5.0.4.2-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 19:25:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-11-25 08:20:53 EST
Version-Release number of selected component (if applicable):
libreoffice-5.0.3.2-4.fc23.x86_64
libreoffice-gtk3-5.0.3.2-4.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. open libreoffice (no component such as writer, but the main window)
2. press the "Extensions" button (bottom in left sidebar)
3. watch your browser and libreoffice console output

Actual results:
Browser doesn't open URL, instead I get this error on console:

Unable to init server: Broadway display type not supported: Wayland
Error: cannot open display: Wayland

Expected results:
Libreoffice should invoke default browser to open URLs

Additional info:
see also bug #1261672 that happened in glib2. Seems to be similiar.
Comment 1 Caolan McNamara 2015-12-15 10:19:54 EST
yeah, stray setenv of DISPLAY on our side leads to the same result
Comment 2 Fedora Update System 2015-12-20 15:46:23 EST
libreoffice-5.0.4.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-98c92e275f
Comment 3 Fedora Update System 2015-12-22 19:11:36 EST
libreoffice-5.0.4.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-98c92e275f
Comment 4 Fedora Update System 2015-12-24 19:25:15 EST
libreoffice-5.0.4.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.